Wie kann ich das in EXCL mit der WENN Formel erreichen?

...komplette Frage anzeigen Ausschnitt 1 - (Computer, Excel, Funktion) Ausschnitt 2 - (Computer, Excel, Funktion)

3 Antworten

Vorschlag:

=WENN(C2<B2;VERKETTEN("Windows 10 ist um ";B2-C2;" schneller als Windows 7");VERKETTEN("Windows 7 ist um "; C2-B2; " schneller als Windows 10"))

Deckt aber nicht den Fall ab, dass beide gleich sind. Die Umrechnung der Zeit-Formatierung in eine Kommazahl müsstest du auch noch basteln.

Antwort bewerten Vielen Dank für Deine Bewertung

=WENN(ABS(B28-C28)<=B28/100;"Gleiche Ergebnisse";INDEX(B$27:C$27;;VERGLEICH(MIN(B28;C28);B28:C28;0))&" ist um "&TEXT(ABS(B28-C28);"[h]:mm:ss")&" schneller")

Ich würde unterstellen, dass ein zeitlicher Unterschied von 1% als gleiches Ergebnis zählt. Wenn es wirklich nur identische Zeiten sein sollen, dann

=WENN(B28=C28;"Gleiche Ergebnisse";INDEX(B$27:C$27;;VERGLEICH(MIN(B28;C28);B28:C28;0))&" ist um "&TEXT(ABS(B28-C28);"[h]:mm:ss")&" schneller")

Antwort bewerten Vielen Dank für Deine Bewertung

in B37:

="Windows " & WENN(B28>C28;"7";"10") & " ist um " & D28 & " schneller als Windows " & WENN(B28<C28;"7";"10")

Das sollte funktionieren (ich probier es gleich aus), ansonsten nur den ersten WENN-Teil, wobei du die sieben und die 10 mit dem jeweiligen Text ersetzt.

Antwort bewerten Vielen Dank für Deine Bewertung
AnonYmus19941 02.11.2016, 13:02

Alternativ kannst du auch einfach in Zelle D28 ff. nur die Differenz nehmen, dann kommen da u. U. negative Werte raus, aber das macht ja auch nichts ...

0
AnonYmus19941 02.11.2016, 13:03

Funktioniert bei mir.

0
calgia 02.11.2016, 13:10
@AnonYmus19941

super danke jetzt zeigt er das ganze in 0.000000 an kann man ihm das auch lernen dass er das in 00:00:00 anzeigt wie oben?

0
offeltoffel 02.11.2016, 13:13
@calgia

Die 00:00:00 ist ja nur eine Anzeige, eine Formatierung. Intern rechnet Excel immer mit den entsprechenden Kommazahlen.

Einfacher wäre es, wenn du generell auf diese Schreibweise umstellst. Am einfachsten geht das über eine Zelle für die Stunden, eine für die Minuten und eine für die Sekunden. Daneben machst du eine Zelle, in die er es in ganze Stunden umrechnet.

2h 24min 37sec = 2 + 24/60 + 37/3600 = 2,410278h

1
AnonYmus19941 02.11.2016, 13:30
@calgia

Folgende Formel (mit gerade einmal 346 Zeichen) wandelt einen Wert in Zelle G5, der dort in Tagen drinnen steht (Standard bei Excel, auch wenn es anders angezeigt wird; dort steht z. B. 0,22 für 5 Stunden), in HH:MM:SS um. Wenn du die Zelle entsprechend anpasst, kannst du sie benutzen. Ob du sie wirklich einsetzen willst, ist dir überlassen ... ;-)

=RUNDEN(UMWANDELN(G5;"day";"hr");0) & ":" & RUNDEN(UMWANDELN(UMWANDELN(G5;"day";"hr")-RUNDEN(UMWANDELN(G5;"day";"hr");0);"hr";"mn");0) & ":" & RUNDEN(UMWANDELN(UMWANDELN(UMWANDELN(G5;"day";"hr")-RUNDEN(UMWANDELN(G5;"day";"hr");0);"hr";"mn")-RUNDEN(UMWANDELN(UMWANDELN(G5;"day";"hr")-RUNDEN(UMWANDELN(G5;"day";"hr");0);"hr";"mn");0);"mn";"sec");0)
0
calgia 02.11.2016, 13:37
@offeltoffel

ich würde lieber die andere anzeige verwenden. gibt es dafür auch eine Lösung?

0
offeltoffel 02.11.2016, 14:16
@calgia

Wäre mir nicht bekannt. Du erzeugst ja einen Text-String, indem du mehrere Elemente verkettest (Funktion "VERKETTEN"). Er wandelt daher jede Zahl in einen Text-String um. Ich kenne keine Option in Excel, die dabei auch gleich eine Formatierung wählt. Du kannst eine Zelle ja nur gesamtheitlich formatieren, also dürfte das schwer werden.

Was funktioniert ist, dass du es doch nicht über 3 verbundene Zellen löst, sondern über drei einzelne.

B37: "Windows 7 ist um ", C37: "00:41:37", D37 " Zeiteinheiten schneller".

Dann kannst du C37 so formatieren, wie du das möchtest.

1
Oubyi 02.11.2016, 15:56
@calgia

Ich misch mich mal ein:
Mit dieser erweiterten Formel von offelfoffel:

="Windows "&WENN(B28>C28;"7";"10")&" ist um "&TEXT(ABS(C28-B28);"hh:mm:ss")&" schneller als Windows "&WENN(B28<C28;"7";"10")

wird der Wert in Stunden, Minuten, Sekunden angezeigt.

Klappt es?

2
calgia 03.11.2016, 08:58
@Oubyi

jaaa erstaulicherweise schon.

1

Was möchtest Du wissen?