Wie kann ich das in Excel machen, damit er mir das entsprechend rechnet?

...komplette Frage anzeigen Seite 1 - (Excel, Formel) Seite 2 - (Excel, Formel)

2 Antworten

Ich habe einmal die von dir geposteten Bilder MIT Namen gemeldet, damit sie nicht zu lange im Netz bleiben. Ich gehe davon aus, dass man es am Bodensee nicht so gerne sieht, wie man mit Mitarbeiternamen umgeht ;-)


Annahme:

Die Spalte C beinhaltet den Abteilungsnamen und die Spalte D ist "x" falls eine Maus ausgegeben wurde:

Die Zusammenfassende Liste der Abteilungen ist in Spalte A ab Zeile 30 und die Liste wird in Spalte B die Anzahl ausgegebener Mäuse haben.

Lösung:

Zelle B30 enhält:

=ZÄHLENWENNS($C$2:$C$21;$A30;$D$2:$D$21;"x")

Erklärung:

Du zählst nur die Einträge, bei denen in C2-C21 Der Abteilungsname aus A30 existiert und GLEICHZEITIG in die Maus Ausgegeben wurde (D2-D21 enthält ein "x")


Die Zelle kannst du dann über die gesamte Spalte nach unten kopieren, um das Entsprechende Ergebnis für jede Abteilung zu bekommen. Für Tastaturen kannst du analog vorgehen.

Nachtrag:

MIt ZÄHLENWENNS kannst du auch mehr als 2 Kriterien hinzufügen, z.B. (Pseudocode)

=ZÄHLENWENN(Abteilungsliste; Abteilungszelle; Mausliste;"x"; Datumsliste;">0")

Antwort bewerten Vielen Dank für Deine Bewertung
=SUMMENPRODUKT((Tabelle1!$C$2:$C$21=$A29)*("x"=Tabelle1!$D$1:$D$21))&" Tastaturen und "&SUMMENPRODUKT((Tabelle1!$C$2:$C$21=$A29)*("x"=Tabelle1!$E$1:$E$21))&" Mäuse wurden in der Abteilung "&$A29&" ausgetauscht!"

und runterziehen.

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von calgia
02.02.2017, 15:01

VIELEN VIELEN DANK aber irgendwie klappt das nicht

lg

0

Was möchtest Du wissen?