wie kann ich das Alter in Jahren in einer neuen Zelle als Dezimalzahl darstellen?

...komplette Frage anzeigen

2 Antworten

Hier geht es wohl darum dass das Jubiläumsjahr wirklich das ganze Jahr so stehen bleibt. Deshalb liefern die Ansätze mit DateDif() und Heute() am Anfang und Ende des Jahres unterschiedliche Ergebnisse.

Kann ich vermeiden, wenn ich nur auf das Jahr abzuziele

=jahr(heute()) - jahr(zelle_mit_geburtsdatum)

Die Auswählerei geht natürlich mit eine geschachelten Wenn-Funktion. Übersichtlicher wird es wenn ich irgendwo einen Bereich von 1 bis 99 anlege und dort die Rückgabewerte eintrage. Dann reicht ein simpler Index

=index(x1:x100 ; 30) 

Könnte man dann mit der obigen Formel kombinieren. Und natürlich den Bereich absolut angeben

=index($x$1:$x$100 ; jahr(heute()) - jahr(zelle_mit_geburtsdatum)) 

Soll es ganz esoterisch werden (oder weil mir der Lookup Bereich nicht gefällt) kann ich den Bereich auch als konstante Matrix angeben

=index({0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;"Geschenk";0;0;0;0;0;0;0;0;0;0;"Geschenk";0;0;0;0;0;0;0;0;0;"Geschenk";0;0;0;0;0;0;0;0;0;"Geschenk";0;0;0;0;0;0;0;0;0;"Geschenk und Urkunde";0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;};jahr(heute()) - jahr(zelle_mit_geburtsdatum))

Ok, da ist dann die geschachtelte Wenn wieder eleganter :-)

Bezieht sich auf Excel!

Wenn in J14 Geburtstag steht, so gib in eine andere Zelle folgendes ein:

=DATEDIF(J14;HEUTE();"y")

So bekommst nur das Alter in Jahren heraus. Den Rest musst du mit der Formel =WENN lösen.

Erkährung für WENN aus Libre Office (kostenlos)

WENN Gibt die durchzuführende Wahrheitsprüfung an. Syntax WENN(Prüfung; DannWert; SonstWert) Prüfung ist ein beliebiger Wert oder Ausdruck, der WAHR oder FALSCH sein kann. DannWert (optional) ist der Wert, der zurückgegeben wird, wenn die logische Prüfung WAHR ist. SonstWert (optional) ist der Wert, der zurückgegeben wird, wenn die logische Prüfung FALSCH ist. In LibreOffice Calc Funktionen dürfen Parameter, die als "optional" gekennzeichnet sind, nur dann ausgelassen werden, wenn ihnen kein weiterer Parameter mehr folgt. So können Sie beispielsweise in einer Funktion mit vier Parametern, von denen die letzten beiden als "optional" gekennzeichnet sind, die Parameter 4 bzw. 3 und 4 auslassen, jedoch nicht Parameter 3 allein. Beispiele =WENN(A1>5;100;"zu klein") Wenn der Wert in A1 größer als 5 ist, wird der Wert 100 in die aktuelle Zelle eingegeben; anderenfalls wird der Text "zu klein" (ohne Anführungszeichen) eingegeben. Verwandte Themen

Was möchtest Du wissen?