WIe kann ich Berechnungen dynamisieren?

3 Antworten

Vom Fragesteller als hilfreich ausgezeichnet

wie berechnen sich denn die "Durchschnitte" (ist hier der arit. Mittelwert gemeint)?
Wenn es schlicht die Summe der Wochenwerte / Anzahl der Wochen gerechnet würde und man je in beiden Jahren die gleichen Wochen vergleicht, kürzt sich ja die Summe der Wochen raus.
Für den Fall könntest du folgende Formel nutzen

=SUMME((B1:B15=2015)*D1:D15)/SUMME((B1:B15=2014)*(A1:A15<=MAX(WENN(B1:B15=2015;A1:A15)))*D1:D15)

dabei sind bei mir:

Spalte A = Kalenderwoche

Spalte B = Jahreszahlen 2014/2015

Spalte D = Indexwert der Summiert werden soll
Die Längen müssen natürlich angepast werden.
Das ganze ist eine Matrixformel also mt Strg+Shift+Enter anschließen.

In jetziger Form werde alle Werte von 2015 addiert und durch die Summe der Werte von 2014 geteilt. Dabei werden von 2014 nur die Wochen addiert, die kleiner oder gleich der höchsten gefundenen Kalenderwoche von 2015 entsprechen.

DH!

Kalenderwoche() selbst eignet sich anscheinend nicht für Matrixformeln (im Gegensatz zu Tag() etc), aber es gibt ja ohnehin eine Spalte mit deren Zahlen.

Der Vollständigkeit halber (und ohne die Qualität deiner AW mindern zu wollen, ich hoffe, der Frager denkt dran, einen zu vergeben!) noch eine Formel für beliebige Grenzdatümer (müssten separat festgelegt werden!) bei Datumslisten (aber noch ohne Quotientenbildung, Datum in Spalte D, D11=1.8.15 bis D21=11.8.15, Chronik-Daten in Sp.C, für KW32=3.8.-9.8.):

=SUMMENPRODUKT((D11:D21>=$D$13)*(D11:D21<=$D$19)*C11:C21)

das IST zwar eine Matrixformel, benötigt aber keine {}


1

Du hast ja bereits die tabelle. Kopier diese an eine stelle, die du nicht brauchst und nicht druckst. Dann ersetzt du jeden wert mit =Wenn('die tabellenspalte/zeile z.b. B3'=0;0;1) Dann kopierst du, indem du auf die zelle und nicht die eingabezeile drückst alles in jede zelle in der werte stehen und in der werte stehen werden. Dann nimmst du die summe aller zahlen in jahr 1 und teilst dies durch die summe von den 1ern und 0ern von oben. Und das gesamte durch das selbe von jahr 2 also =(summe(z.b.B3:M5)/SUMME(B6:M8))/Das selbe. Denk daran das du bei der summefunktion auch schaust welche werte in zukunft kommen werden.

Da fehlen einfach Informationen!

Ganz ehrlich?? Übertreibst du nicht mit diesen Statistiken?

Die zusammengestellten Werte der KW 27 2014 und der KW 27 2015 sind rein zufällige Werte. Wenn man die dividiert, hat man zwar ein „Ergebnis“. Nur frage ich mich, was man mit so einem Ergebnis anfangen könnte bzw. soll? Zumindest verstehe ich deine Informationen so … :-)

Zwar hatte ich mal eine ähnliche Statistik in der es um Energie-Messstellen ging. Die wurde jedoch monatlich fortgeführt!

Zum einen habe ich damit geprüft, ob die aktuelle Monatsmessung „stimmig“ ist und wenn man dies über Jahre zusammenstellt, lassen sich Verbrauchstrends ablesen.

„Stimmig“ heißt in diesem Zusammenhang, wenn der Verbrauch „0“ ist, war die Messstelle zu prüfen und mit dem Verbraucher zu reden, warum nichts verbraucht wurde und wenn der Verbrauch plötzlich ab 2 … 200 mal mehr war, musste man dem auch nachgehen und die Ursachen klären!

Ein Wäschetrockner mit Energieeffizienzklasse A+++ wird mit 176 kw/h im Jahr angegeben. Wie bekomme ich heraus was dieser in der Stunde verbraucht?

Wenn ein Wäschetrockner mit 176 kw/h angegeben wird, wie bekomme ich heraus was dieser in der Stunde verbraucht? Von welchen Daten wird davon ausgegangen? Geht das von einem 4 Personenhaushalt aus bei dem mehrmals am Tag der Trockner läuft? Mein jetziger verbraucht ca. 1,7 kw/h. In welcher Effizienz Klasse ist der?

...zur Frage

Was für eine.note habe ich?

Hey und zwar habe ich bis zum halb Jahr Mathe fertig (also mit Arbeiten und so) ich habe ein mal eine Note 1,1 und Note 2,5 (Arbeit) mündliche habe ich mal eine 2,2 und ne 2,0

Unser Lehrer meinte Arbeiten Zählen 3:1 (3 zu 1) auf mündlichen, so was ein Durchschnitt habe ich dann?? Bzw welche Note im Zeugnis. Da ich keine ahnung habe wie man mündlich und Schriftlich zusammen wertet

Danke für antworten oder Berechnungen:)

...zur Frage

stromverbrauch elektroheizungen

wir haben neue heizungen von jawo. (elktroheizung). mein vermieter sagt, wir kommen im jahr auf ca 5-6000 KW. ich lese jeden tag den strom ab und verbrauche täglich um die 40 KW. das wären ja im jahr fast 12000 KW. kann das sein? es laufen 4-5 heizungen auf 19 grad. das braucht ja im schnitt ein komplettes Haus.

...zur Frage

Welches dieser 4 Notebooks für‘s Business?

Hallo, ich habe mit ca 10 gestartet und habe noch 4 und kann mich nicht entscheiden. Ich benutze es meistens fürs business (niemals gaming, manchmal videos, und sonst halt normale arbeitsbedingte Aktivitäten). Ich habe lange verglichen und bin verzweifelt.

Vielen Dank für die Hilfe

https://www.notebooksbilliger.de/produkt+vergleich/category/2/show/326572:0,320941:0,316056:0,352437:0

...zur Frage

KWs in Excel rechnern über Jahresgrenzen hinweg?

Hallo zusammen, ich habe eine Frage zum Thema Excel rechnen mit Datum.

Ich habe eine Tabelle, hier ist Spalte A der Tag, B die KW und C das Jahr und danach Beschreibung, Kommentare etc.

Nun ist zwischen den einzelnen Zeilen ein Bezug, den ich gerne automatisiert darstellen würde. Solange ich mich in einem Jahr bewege alles kein Problem, aber gibt es eine Möglichkeit, um Beispielweise bei in Zeile 1 KW 40 stehen habe und in B da 20 Wochen hinzu zähle und Excel automatisch ins nächste Jahr springt und nicht KW60?

Danke für eure Hilfe :)

...zur Frage

Technische Daten bei einer Fräsmaschine

Hi an alle, könnte mir jemand den Zusammenhang von dieser Motorleistung erklären:

Antriebsleistung max. ...... 40 % ED ...... 35 kW Nennleistung ..................... 100 % .......... 25 kW

Am Liebsten wäre es mir wenn ich es ganz genau erklärt bekomme damit ich es auch jemanden anderen erklären kann.

Dann noch eine Frage zum Drehmoment:

Maximales Spindeldrehmoment .......... 40 % ED ........ 130 Nm Nenndrehmoment ................................... 100 % ED ..... 87 Nm

Dann noch was beides betrifft. Warum werden die werte in 40 % angeben und nicht 100? Was ist da für ein Grund dahinter und was heißt ED?

Schon mal danke für die Antworten

...zur Frage

Was möchtest Du wissen?