Wie kann ich bei Excel Mehrfacheintragungen mit der Zählenwenn-Funktion zählen?

4 Antworten

Hallöle,

wenn die auszuwertende Liste Deiner verschiedenen Länder z.B. in der Spalte B steht von der 2. bis zur z.B. 173. Zeile dann müßte Deine Formel um zu zählen wie oft Polen drin vorkommt so aussehen:

=ZÄHLENWENN(B2:B173;"Polen")

Damit steht dann dort nur die Zahl "3". Wenn Du möchtest, dass dort steht:  "Polen = 3", dann verwende folgende Formel:

="Polen = "&(ZÄHLENWENN(B2:B173;"Polen"))

Wenn Du mehrere Zählergebnisse genannt haben möchtest, z.B. Polen und Frankreich, kannst Du das auch kombinieren:

=("Polen = "&(ZÄHLENWENN(B2:B173;"Polen")))&(", Frankreich = "&(ZÄHLENWENN(B2:B173;"Frankreich")))

Dann würde dort nacher z.B. stehen:

Polen = 17, Frankreich = 25

Schöne Grüße,

wölfin

Ich hatte es so verstanden, dass der Fragesteller wissen will, wieviele [sic] verschiedene Länder vorkommen, also 3 Länder im Beispiel.
Nicht, wie oft jedes einzelne vorkommt.
Mal sehen, wer richtig liegt,
FALLS noch eine Rückmeldung kommt.

1
@Oubyi

Hmm, stimmt, das könnte er auch gemeint haben! 😐

Ich habe die von ihm im Beispiel genannte 3 damit verbunden, dass Polen 3x genannt wurde, nicht, dass er drei verschiedene Länder aufgezählt hat. Naja, mal gucken, ob sich das Rätsel noch löst! 😊

1

Mit einer einfachen ZÄHLENWENN-Funktion allein kommst Du da nicht weiter. In der Excel-Hilfe sind ziemlich komplizierte Funktionen als Lösung angegeben, in denen man die Werte xmal als Matrix eingeben muss. Schon allein dass die sich da selbst (bei den Beispielen) verschrieben haben, zeigt, dass man sich da leicht vertun kann.

Wenn es Dir nichts ausmacht, doppelt vorkommende Zellen zu löschen, kannst Du den Bereich, in dem Du die doppelten Einträge entfernen möchtest, markieren. Mit 'Daten' ==> 'Duplikate entfernen' entfernst Du alle Duplikate. Dann brauchst Du die übrig gebliebenen Zellen nur noch mit ANZAHL2 zu zählen.


Auf die Schnelle mal eine Lösung mit Hilfsspalte.
Angenommen die Länder stehen in Spalte B.
Dann in C1 diese Formel und runterkopieren:

=WENNFEHLER(1/ZÄHLENWENN($A$1:$A$1000;A1);0)

und in z.B. D1:

=SUMME(B1:B1000)

Klappt es?

Excel-Formel LINKS in Zählenwenn einbinden, wie?

Hallo zusammen, Ich kann die Excel-Formel LINKS nicht in die Zählenwenn Formel einbetten, was mache ich falsch?

Ausgangslage:

Spalte A

  • Hans
  • Franz
  • Marie

Spalte B

  • 01.07.1987
  • 02.02.1988
  • 01.04.1990

Wenn ich nun zählen möchte wie viele Personen am 01. eines Monats Geburtstag haben, würde ich folgende Formel einsetzen:

=ZÄHLENWENN(LINKS(B:B;2);"01")

Warum funktioniert diese Formel nicht, was mache ich falsch? Wichtig ist, dass ich keine hilfszellen erstellen darf, die Anzahl soll mit einer Formel ermittelt werden können.

Vielen Dank für eure Hilfe! Gruss Reti

...zur Frage

Teil eines Wortes in Excel suchen?

Also ich möchte mit der Zählenwenn-Funktion ein nach einem Bestimmten Teil eines Wortes suchen. Damit meine ich zum Beispiel: das "mann" von kaufmann Ich dachte so an =Zählenwenn("%mann%") aber das funktioniert nicht. Habt ihr einen Ansatz?

...zur Frage

Ergebnis eines SVERWEIS als Teil des Bereichs bei der Zählenwenn Funktion?

Ich habe einen extra Tabellenbereich für den SVerweis. Das Ergebnis des SVERWEIS alleine ist korrekt. Aber ich möchte das Ergebnis des SVERWEIS als Teil des Bereichs bei einer ZÄHLENWENN Funktion einfügen.

SVERWEIS(A3;Info;2;WAHR) In A3 steht ein einzutragendes Datum. Dieses sucht der SVERWEIS in seiner Liste und gibt dann in meinem Falle "BX5" wieder.

ZÄHLENWENN(B5:BX5;"22") Hier soll er aufsteigen zählen, wenn er in dem Bereich eine "22" findet. Macht Excel auch alles, aber wenn ich

ZÄHLENWENN(B5:SVERWEIS(A3;Info;2;WAHR);"22") den SVERWEIS anstatt der "BX5" setzte kommt eine Fehlermeldung

...zur Frage

Excel ZÄHLENWENN mit relativen Bezug auf Zelle oberhalb der aktuellen

Hallo,
Ich habe eine Tabelle, in der ich die erste Spalte auf Duplikate überprüfen möchte.
Dazu sorteiere ich diese Spalte (alles Zahlen) in aufsteigender Reihenfolge und möchte nun die "Zählenwenn"-Funktion verwenden, um die Duplikate zu zählen.
Da die Spalte ja sortiert ist kann ich sicher sein, dass gleiche Zahlen immer übereinander liegen, sodass ich in der "Zählenwenn"-Funktion folgendes haben möchte:

=ZÄHLENWENN(Bereich;Inhalt=Inhalt der Zelle oberhalb)

Die Zählenwennfunktion durchläuft ja alle Zellen im Bereich, weshalb (theoretisch) die Funktion "Adresse()" mit "Zeile()" und "Spalte()" als Parameter die aktuelle Zelle referenzieren/sich darauf beziehen.
Das würde bedeuten, dass ich in der "Zählenwenn"-Funktion als zweiten Parameter eigentlich nur folgendes eingeben müsste:

Adresse(Zeile()-1;Spalte())

Funktioniert nicht.
In einigen Beispielen habe ich gesehen, dass Bezüge auf andere Zellen in der "Zählenwenn"-Funktion mit einem "&" beginnen, also habe ich folgendes versucht:

=ZÄHLENWENN(A2:A3000;&ADRESSE(ZEILE()-1;SPALTE()))

Wieder kein Erfolg.

Deshalb die Frage: Wie kann ich in der "Zählenwenn"-Funktion in Excel mich auf eine Zelle, relativ zur aktuellen beziehen? Das hier genannte Beispiel wird sicher auch anders zu lösen gehen, aber den genannten relativen Bezug (also relativ zur Aktuellen Zelle) könnte man in der Zählenwenn schon öfters brauchen. Danke und lg, Springrbua

...zur Frage

Zählenwenn Excel mit 100 Kriterien?

Hallo Liebe Community,

Ich hab eine recht komplexe Excel Tabelle mit ein paar tausend Zeilen.

Nun möchte ich in einer Spalte die Zellen zählen lassen, in welcher ein bestimmtest Kriterium vorkommt. Vom Prinzip bekomme ich es hin, nur leider habe ich über hundert Kriterien die überprüft und gezählt werden sollen.

Meine Frage nun ist, wie ich dieses Problem möglichst leicht lösen kann?

...zur Frage

Excel Anzahl einfügen?

Ich muss zu dieser Liste die Anzahl der Anwesenheit eintragen. Kann man dafür wine Formel verwenden?

...zur Frage

Was möchtest Du wissen?