Wie kann ich bei Excel bei SUMMEWENNS kriterium A oder B auswählen?

... komplette Frage anzeigen

2 Antworten

Die Bedingungen in SUMMEWENNS werden und-verknüpft. Mit ODER-Verknüpfungen in SUMMEWENNS bin ich gerade überfordert.

Du könntest dir aber die Funktion SUMMENPRODUKT zur Hand nehmen:

=SUMMENPRODUKT(((A:A="Obst/Gemüse")+(A:A="Fleisch/Geflügel"))*((B:B="DE")+(B:B="GB"))*(C:C>=50)*(C:C<=150)*C:C)
Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Oubyi
27.12.2015, 17:27

Mit ODER-Verknüpfungen in SUMMEWENNS bin ich gerade überfordert

Einfache mehrere SUMMEWENNS-Funktionen addieren.
Aber schön finde ich SUMMEWENNS trotzdem nicht, meide diese Funktion und lösen so etwas auch immer mit SUMMENPRODUKT.

0

Muss es Summewenns sein?

Ich würde es so machen

=SUMMENPRODUKT((ODER(A2:A99="Obst/Gemüse";A2:A99="Fleisch/Geflügel"))*(ODER(B2:B99="Deutschland";B2:B99="Großbritannien"))*(UND(C2:C99>=50;C2:C99<=150))*(C2:C99))

(ungetestet)

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von PatPat1992
27.12.2015, 18:57

=SUMMENPRODUKT((ODER(B:B="Obst/Gemüse";B:B="Fleisch/Geflügel"))*(ODER(G:G="Deutschland";G:G="Großbritannien"))*(UND(P2:P2156>=50;P2:P2156<=150))*(P2:P2156))

So habe ich es nun eingetippt aber am Ende kommt 0 raus (0 ist die falsche Lösung). 

0
Kommentar von augsburgchris
27.12.2015, 22:20

Du kannst keine Oder Beziehung in einer Arrayformel verwenden. Wenn dann musst du mit + und * arbeiten.

2
Kommentar von augsburgchris
27.12.2015, 22:24

=SUMMENPRODUKT(((B:B="Obst/Gemüse")+(B:B="Fleisch/Geflügel"))*((G:G="Deutschland")+(G:G="Großbritannien"))*(P2:P2156>=50)*(P2:P2156<=150)*(P2:P2156))

2

Was möchtest Du wissen?