Wie kann ich bei Excel 0.5s und s zu 1.5s zusammenzählen lassen?

... komplette Frage anzeigen

5 Antworten

Naja, das ist eine der Schwierigkeiten wenn man Excel als Datenbank einzusetzen versucht.
Excel ist nicht dafür gedacht, in einer Zelle viele verknüpfte Infos zu verwalten.
Natürlich kann man mit Textfunktionen nun irgendwie die Zahl der beim S steht extrahieren und auch die Anzahl der S ermitteln - aber der Teufel steckt im Detail, dabei an jede mögliche Fehleingabe und alle Formeln so auszulegen, das Fehler entweder kompensiert werden oder als Fehler angezeigt ist schwer.
Kombinierte Eingaben aus Zahl und Text sind für Excel intern eh immer ein Text - Sowas planmäßig als Rechengrundlage zu nutzen ist nicht gut.
Ich empfehle daher strickte Trennung.
Statt einer Spalte die die Abwesendheit an diesem Tag dokumentiert, gehören da 2 Spalten hin. Eine Spalte für Urlaub und eine für Krank. In den Zellen wird dann jeweils nur 0,5 oder 1 für einen ganzen oder halben Tag eingetragen. So kann alles sauber zusammengerechnet werden und mit entsprechenden Formatierungen kann man auch einen leichte optische Kontrolle erreichen.

Antwort bewerten Vielen Dank für Deine Bewertung

Das geht so (ob es sinnvoll ist, ist eine andere Frage!):

=SUMMENPRODUKT(WECHSELN(A1:A2;"s";"")*1)

Da Wechseln keinen Fehler liefert, wenn der Siuchstring nicht gefunden wird, werden auch normale Zahlen mitaddiert..

Hast Du allerdings einen anderen Buchstaben wahlweise dran, dann musst Du für jeden (sofern unterschiedlich) ein weiteres Wechseln einbauen, zB U:

=SUMMENPRODUKT(WECHSELN(WECHSELN(A1:A3;"s";"");"u";"")*1)

[Gross/klein wird nicht unterschieden].

Nimm im übrigen -wenns die Firmenkonvention erlaubt- anstatt s für sick ein k für krank, ich hab zunächst gedacht, Du willst Zehntelsekunden zusammenzählen!

Vermeide also T, M, J, h, m, s im deutschen Excel und im englischen d, m, y, h, m, s, wenn es sich um Zeiten handelt. Je nach Konstellation könnte es sonst in Textdarstellungen Probleme geben.

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Iamiam
02.05.2016, 16:45

lese grade nochmal Deine Frage durch:

Wenn Du NUR die Zahlen mit s zusammenzählen willst (und die blanken Zahlen nicht und auch keine mit anderen Buchstaben, dann brauchst Du eine Matrixformel:

=SUMME(NICHT(ISTFEHLER(SUCHEN("s";A1:A3;1)))*WENNFEHLER(WECHSELN(A1:A3;"s";"")*1;0))

Damit zählst Du definitiv nur die Zahlen zusammen, in denen s vorkommt.  Andere EinzelBuchstaben werden ignoriert, auch Kombinationen, sofern dort kein s enthalten ist,

Achtung: Dies ist eine Matrixformel! Die geschweiften {Klammern} NICHT miteingeben, sondern die Formel anstatt mit einfachem Enter mit der Kombination (gleichzeitig) Strg+Shift+Enter abschließen (nach jeder Neubearbeitung wieder!). Die {Klammern} entstehen dann automatisch.

Schreibtechnisch nimmst Du am besten die rechte Strg- und Umschalttaste, dann gehts mit einer Hand und lässt sich auch leichter merken!  - - -

Noch ein Tipp: Wenn Du in der Bearbeitungszeile einen selbständigen Formelteil markierst und F9 drückst, erhältst Du ein(e) Ergebnis{liste}. Allerdings dann die Zelle mit Esc verlassen (oder rückgängig machen), Enter würde das gezeigte Ergebnis festschreiben! Vorläufig kurze Bereiche festlegen! (mindestens 2 Zellen markieren, Strg+h, ... ersetzen durch ...) --

0

Ja, das geht schon. Das reine Summieren geht z.B. so

=LINKS(A1;FINDEN("s";A1)-1)+LINKS(A2;FINDEN("s";A2)-1)

wobei in A1 z.B. 0,5s steht. So summierst du die reine Zahl in der Zelle bzw. gibst diese zurück. Das ganze spuckt einen Fehler aus, wenn kein "s" gefunden wird

--->

Du müsstest jetzt also noch eine Überprüfung aufbauen, dass alles mit "s" summiert wird. Das würde wahrscheinlich am einfachsten mit einer Hilfsspalte gehen.

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Jackie251
02.05.2016, 10:26

die Summe ist so nicht sinnvoll, da für jeden Summanden geprüft werden muss ob es eine Zahl ist.
wenn man das dann aber als Summe für einen Monat hintereinander hängt, steigt Excel vermutlich schon wegen der Formellänge aus.

Um Fehler abzufangen müsste man dann sowas in der Richtung zusammenbauen:

=WENN(RECHTS(A1;1)="s";LINKS(A1;LÄNGE(A1)-1)*1;A1)

und summieren

oder mit

=SUMME(WENN(RECHTS(A1:A31;1)="s";LINKS(A1:A31;LÄNGE(A1:A31)-1)*1;A1:A31))

direkt die Summe anfordern (Matrixformel mit Shift+Strg+Enter abschließen)

aber wenn man eh eine Hilfspalte baut, kann man auch gleich die Eingabe in 2 Spalten trennen

0

Es gibt keine Möglichkeit in der man einzelnen ausdrücken Werte zuordnen kann? Z.B. 0.5S ist gleich 1/2, S ist gleich 1?

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Iamiam
02.05.2016, 14:22

doch, siehe meine AW!

0

halbe Urlaubstage? Gibt es nicht. Entweder man hat Urlaub, oder nicht.

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Funfroc
02.05.2016, 10:02

So ein Käse. Es gibt keinen gesetzlichen Anspruch auf halbe Urlaubstage, das hindert den Arbeitgeber aber nicht daran, diese trotzdem zu gewähren.

0
Kommentar von ghanaboy
02.05.2016, 11:21

Danke für die Antwort. Dies ist allerdings keine arbeitsrechtliche Frage sondern ein Excel-problem! In Indien bei uns in der Firma gibt es zudem definitiv halbe Urlaubstage. 

0

Was möchtest Du wissen?