Wie kanmn ich den Wert einer Zelle teilen und dann ideal aufteilen?

... komplette Frage anzeigen

2 Antworten

  • Am einfachsten geht’s, wenn du auch den Preis auf 25kg normierst. 
  • Die zur Verfügung stehende €Summe stehe in A1
  • Obiger auf 25 kg genormter SandPreis€/25 kg in A2,
  • der Preis für den Lagerplatz je 25kg in A3.
  • Die Formel ist dann
  • =Abrunden(A1/(A2+A3);0)*25 kg oder
  • =Ganzzahl(A1/(A2+A3))*25 kg


Abrunden bzw Ganzzahl ist notwendig, weil Du ja nur ganze Lagerplätze mieten kannst. Zwangsläufig kannst Du so nur ausnahmsweise alles Geld ausgeben, wenn nämlich Summe(Lagerplatz+Preis)je 25 kg ganze Vielfache der Summe in € ergeben (blöd formuliert)

Praktisch stimmt das allerdings nicht (es sei denn, der Sand wird in Boxen gefüllt (so wie die dreieckigen Streusandhäuschen oft am Straßenrand): da der SchüttKegel  als Volumen zunimmt, die nötige Kegelfläche aber als Fläche, ergibt sich über Verhältnis von Lagerplatz-Länge zu LagerplatzFläche zu SandVolumen von L³/L², es ist mir aber jetzt zu kompliziert, das normiert auszurechnen.

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Iamiam
10.09.2016, 09:40

Ich hab die Situation vergessen, dass das Geld darüberhinaus für einen Teil-aufgefüllten Lagerplatz noch reicht. also Formeln ergänzen bzw umschreiben:

  • =GANZZAHL(A1/(A2+AA3))+(REST(A1;A2+A3)>A3)+N("Lagerplätze")
  • und 
  • =(A1-[Lagerplätze]*A3)*25+N("kg Sand")

Das heißt in Geld:

  • FürLagerplatz
  • =Lagerplätze*Preis/Lagerplatz[A3] 
  • und 
  • FürSand 
  • =kgSand*Vorgabepreis/kgSand 
  • (oder /to Sand / 1000)
  • Muss in der Summe wieder A1 ergeben, nur dann weniger, wenn der Rest <Kosten für einLagerplatz ist
0

Es sind ja zwei Informationen (benötigter Lagerplatz + Menge Sand). Das in eine Zelle zu pressen ist möglich, aber nicht unbedingt hilfreich, weil das jeweilige Ergebnis für Lageplatz bzw. Sand nicht als reine Zahl vorliegt, mit der man weiterrechnen kann. Daher sollte man das sinnvollerweise trennen.

Die Berechnung selbst ist eher ein mathematisches Thema, kein Excelproblem -> nix wirklich für mich ehrlich gesagt. Ich hab mal was zusammengewürfelt.

Formel für B6 (Lagerplatz):


=WENN(GANZZAHL(B1/(25*B3+B4))<B1;GANZZAHL(B1/(25*B3+B4))+1;GANZZAHL(B1/(25*B3+B4)))

Formel für B7 (Sand)

=GANZZAHL(B1/(25*B3+B4))*25+((B1-GANZZAHL(B1/(25*B3+B4))*(25*B3+B4)-B4)/B3)

Antwort bewerten Vielen Dank für Deine Bewertung

Was möchtest Du wissen?