Wie die Wenn Formel im Excel erstellen?

... komplette Frage anzeigen

4 Antworten

Nehmen wir an, du willst A2 in Abhängigkeit von A1 einfärben.

  1. Markiere A2
  2. Wähle als Hintergrundfarbe rot (unter Start → Schriftart)
  3. Start → Formatvorlagen → Bedingte Formatierung → Neue Regel...
  4. Formel zur Ermittlung... : =A1=1
  5. Dann das Format der Hintergrundfarbe auf grün festlegen
  6. Den Dialog mit OK verlassen

(Excel 2010)

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Catmami
28.06.2016, 15:56

Das hat schon mal super geklappt mit den Farben, danke! Weisst du auch, ob ich meine beiden Fragen sozusagen kombinieren kann? Also dass es grün wird, wenn der Wert zwischen x und y liegt? Das wäre der hammer!

0

Wenn Zelle x zwischen dem Wert in Zelle y und dem Wert in Zelle z ist,
beispielsweise zwischen 40 und 60, dann soll da in der Zelle ok stehen,
Wenn die Zahl kleiner als 40 oder grösser als 60 ist, soll da falsch
stehen

Diese Formel z.B. in Zelle W1:

=WENN(UND(X1>=Y1;X1<=Z1);"ok";"falsch")

Je nachdem , was bei genau 40 oder 60 passieren soll, musst Du die "="-Zeichen weglassen.

Antwort bewerten Vielen Dank für Deine Bewertung

Farbige Markierungen erreichst du mit der Funktion "bedingte Formatierung"

Die Formel: =WENN(UND(A1>=40;A1<=60);"falsch";"")

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Catmami
28.06.2016, 15:57

Das mit der Farbe hab ich nun schon mal hingekriegt, danke :) Die Formel funktioniert bei mir aber leider irgendwie nicht, oder jedenfalls nicht immer

0

  
  



WENN ein Kunde mehr als 1000 Euro Umsatz generiert hat, DANN soll er 10% Rabatt bekommen, SONST bekommt er keinen Rabatt.















Die
WENN Funktion hat immer 3 Schritte (s.g. Argumente):








WENN:
die Bedingung oder Prüfung – Hier: ein Kunde generiert mehr als 1000 Euro
Umsatz,





DANN:
was tun, wenn die Bedingung stimmt – Hier: 10% Rabatt berechnen,






SONST:
was tun, wenn die Bedingung nicht stimmt – Hier: 0,00 € schreiben.






Übe mal selbst
  

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Suboptimierer
28.06.2016, 15:24

Sind die vielen Leerzeilen unbedingt nötig?

1
Kommentar von Catmami
28.06.2016, 15:25

Joa, so krieg ich die Wenn-Formel hin. Aber ich brauch bei dem WENN ein 500 - 1000 Euro als Bedingung..

0

Was möchtest Du wissen?