Wie cluster ich bei Excel Zellen bei bestimmter Bedingung?

2 Antworten

Vom Fragesteller als hilfreich ausgezeichnet
B1: Apfel
B2: =WENN(LINKS(A2;LÄNGE($B$1))=$B$1;TEIL(A2;LÄNGE($B$1)+2;1024);"")
B3: =WENN(LINKS(A3;LÄNGE($B$1))=$B$1;B2&","&TEIL(A3;LÄNGE($B$1)+2;1024);B2)

B3 herunterziehen

2

Vielen Dank schon mal für den Ansatz. So ganz ist es das aber noch nicht. B1 ist ja Kommentar und Apfel ist in A2. Nochmal zur verdeutlichung:

A1: Obst B1: Kommentar


A2:Apfel B2 lecker


A3: Apfel B3: super

usw.

0
58
@huegel42

Dann ist es noch simpler

C1: Apfel
C2: =WENN(A2=$C$1;B2;"")
C3: =WENN(A3=$C$1;C2&","&B3;B3)

C3 herunterziehen. Es werden alle Apfelkommentare in der untersten Zeile von C aufgelistet.

0
2
@Suboptimierer

Für Apfel funktioniert das, aber nach Apfel kommt ja in A5 bis A8 Birne; A9 bis A11 Melone usw. Dafür wird das dann nicht automatisch übertragen. Ich glaube fast, dass geht nicht so wie ich mir das vorstelle.

0
58
@huegel42

Wenn die Früchte sortiert untereinander stehen, lautet der fehlende Schritt zur Lösung, einfach nur einen Fruchtwechsel zu erkennen.

C2: =B2
C3: =WENN(A3=A2;C2&","&B3;B3)

Dann C3 herunterziehen.

0

Das Format wollte leider nicht so wie ich. Hoffe so wird es eindeutiger:

Obst Kommentar C1


Apfel lecker C2


Apfel super C3

Wie kann ich in Excel mein Warenlager mit vorhandene Rezepturen abgleichen. Um zu wissen wieviel ich Herstellen kann?

Guten Tag

Ich hab eine etwas komplexes Problem und hoffe es halbwegs vernüftig erklären zu können. Damit mir jemand helfen kann.

Ich möchte das Excel mein Warenlager mit verschiedenen Rezepturen abgleicht und mir sagt, wieviel komplette Rezepturen man herstellen kann. Das Bild sollte ungefähr ein Einblick zu meiner Frage geben.

Im Bild sieht man das unter der Rezeptur 1 ab B4 bis B7 Zahlen stehen die Excel mit dem Warenlager rechts ab I4 abgleichen soll. Wenn von allen Zutaten genug für eine Herstellung ist, sollte in der Mitte bei D4 eine ganze natürliche Zahl dargestellt werden.

Rezept 2 beginnt bei B10 bis B14 gleicht das identische Lager ab und gibt bei E4 die maximal mögliche Menge an.

Bei D4 und E4 sollten im Idealfall nun jeweils die Menge erscheinen die man herstellen kann.

Sofern das erreicht ist!

Nun eine Erweiterung des Ganzen:

Wenn bei D4 als Beispiel 8 steht, also ich 8mal die Rezeptur 1 herstellen kann. Möchte ich das sobald ich bei D6 (Wieviel ich tatsächlich hergestellt habe) einen Wert eingeben sich die beiden obrigen (D4 & E4) ändern. Weil sich ja nun das Lager ändert, wegen die nun hergestellten Ware.

Ich hoffe das es jemand gibt der versteht was ich damit sagen möchte. Ergänze auch gerne sofern unklarheiten aufkommen.

Liebe Grüße Akki

...zur Frage

Wie heißt die Mischung aus Apfel und Birne?

Meine Mom hatte einen halben Apfel aufm Teller liegen, dachte ich. Es ist aber eine Mischung auf Apfel und Birne... Es schmeckt wie Birne, ist aber von Schale, Form und vom Festen her wie ein Apfel. Schmeckt irgendwie lecker. Bloß wie heißt das Ding?

...zur Frage

Microsoft Excel Funktion Formel Wenn Verketten?

Hey Community,
ich habe ein Problem mit einer sehr langen VERKETTEN-Funktion.
Ich habe eine Tabelle mit ca. 400 Zeilen... und 80 Spalten... In einer Spalte... sollen dann zu jeder Zeile... die 80 Spalten verkettet werden... allerdings gibt es Zeilen,wo nur 20 von 80 Spalten einen Wert aufweisen... Deshalb nimmt excel beim verketten dann sehr viele leere Zellen mit in die eine Zelle... Kann man irgendwie eine Formel schreiben, die sagt: „Wenn eine Zelle leer, dann beachte Sie nicht und gehe eine Zelle weiter.“???
Dankeschön 😉

...zur Frage

Excel automatischer Filter oder Ausblendung Zeile?

Hallo,

ich habe eine Tabelle mit 2 Reitern.

Von Tabelle Alpha werden per Formel die Zeilen beginnend ab C7 - C40 kopiert wenn ein "x" in Spalte B eingefügt wird und nach Tabelle Beta kopiert.

Problem ist jetzt das wenn sich zwischen den zu kopierenden "x" auch ein anderer Buchstabe befindet ( Zeile die nicht kopiert werden soll) ich in Tabelle Beta nun eine 1:1 Kopie erhalte und ich bei jeder Zeile einen Abstand habe. ich hätte gerne alle eingefügten Zeilen untereinander ohne Lücke.

Sicherlich eine Kleinigkeit in der Formel aber bin nicht drauf gekommen.

Formel ist momentan so:

=WENN(Alpha!$B$7:$B$40="x";Alpha!C7;)

...zur Frage

Welche Excel Formel kann ich verwenden, wenn für eine Zelle je drei Berechnungen erfolgen sollen?

Hallo, zuerst die Problematik mal beispielhaft beschrieben:

Mit den untereinander stehenden Werten eines Arbeitsblattes in Spalte C (Bsp. C2, C3, C4, ...) , sollen auf einem Arbeitsblatt 2 jeweils drei Multiplikationen untereinander erfolgen (Bsp. =C2*0,5 / *0,9 / *1,5), danach kommen die gleichen 3 Rechnungen für die nächste Zelle (Bsp. C3). Das soll nun oft wiederholt werden.

Beim manuellen Weiterziehen der Formel (Markieren und Formel weiterziehen) erkennt Excel leider nicht, dass der Bezug der Zelle drei Mal vorliegt und dann erst weiterspringt)

Welche Formel kann ich verwenden?

...zur Frage

Wie kann ich in Excel viele Zellen einer Spalte miteinander verketten/ Gibt es die Möglichkeit bestimmte Bereiche automatisch zu einer Zelle zusammenzufügen?

Hallo, ich habe eine extrem lange Liste bestehen aus zwei Spalten. In Spalte A sind Zahlen und in Spalte B sind Wörter.

Frage 1: Wie kann ich bestimmte Bereiche in eine Zelle zusammenfügen; am besten durch Komma getrennt. Was ich bislang gefunden habe erscheint mir etwas kompliziert: VERKETTEN(MTRANS(B1:B67)) Dann kommt da sowas raus: {"Nähe"."Nu"."Uni"."Hahn"."Neue"."Huhn"."On"."Yen"."Nahe"."Hohn"."Ion"."Henne".} Hier mache ich nun mit Ersetzen die Anführungszeichen und die Klammern weg und aus dem Punkt ein Komma mit Leerzeile. Geht das nicht irgendwie noch leichter?

Frage 2: Könnte man auch gleich befehlen, dass alle Wörter, denen in Spalte A die gleiche Zahl zugeordnet ist, in einer Zelle zusammengefasst werden?

So sieht das ganze etwa aus:

A B

1 Eid

1 Hoheit

1 Hit

1 Heute

2 Huhn

2 Henne

3 Mühe

3 Oma

3 Heim

usw. Die Liste hat an die 270.000 Einträge (Zeilen). Die Zahlen in Spalte A gehen bis 99999. Daher sollte so viel wie möglich automatisch laufen. Denn fast einhunderttausend Einträge (so wie ich es bislang von Hand mache) zu ändern ist der Horror ... Ein Freund sagte mir, ich brauche wahrscheinlich ein Makro. Allerdings habe ich überhaupt keine Ahnung wie ich das verwende. Daher bitte ich um eine ausführliche Erklärung und hoffe, dass ich nicht zu viel verlange...

Vielen vielen lieben Dank schonmal. Ich hoffe und freue mich auf Antworten

...zur Frage

Was möchtest Du wissen?