Wie bilde ich per Excel Formel einen Wochentag auf einen anderen ab?

2 Antworten

Du benötigst ein Mapping.

=SVERWEIS(A1;{"Montag"."Dienstag";"Dienstag"."Mittwoch";"Mittwoch"."Donnerstag";"Donnerstag"."Freitag";"Freitag"."Samstag";"Samstag"."Sonntag";"Sonntag"."Montag"};2;0)

Die Hilfstabelle kannst du dir auch irgendwo in ein Hilfsblatt legen.

Hi Sub:

hä warum ein Mapping? Mit meiner Lösung wäre das nicht notwendig... sehe ich was nicht?

0

das kommt darauf an in welchem Format der Montag in Zelle A1 steht.

ist es Text oder ein Datum?

Text ist es

0
@Perfekturius

das ist doof. Formatiere A1 in Benutzerdefiniert und "TTTT"

verwende nun in A1 die Funktion

=WOCHENTAG(2;1)

in X25 kannst Du nun folgendes eingeben:

=A1+1

das gilt für Dienstag, Mittwoch wäre dann +2 usw.

1
@Perfekturius

das geht nur wenn es ein Datum ist. Du hast aber geschrieben es sei Text

0

Was möchtest Du wissen?