Wie berechne ich Nachtarbeit bei der Zeiterfassung?

... komplette Frage anzeigen

3 Antworten

Probier mal folgende Formel. In diesem Beispiel stehen Anfangs- und Endzeit in A2 und B2. Die Zellen sind im Uhrzeit-Format.

=WENN(B2<A2;1-MAX(A2;20/24);MAX(B2-20/24;0)-MAX(A2-20/24;0))

Wenn die Zellen nicht im Uhrzeitformat sind und du Dezimalzahlen verwendest, dann lautet die Formel:

=WENN(B2<A2;24-MAX(A2;20);MAX(B2-20;0)-MAX(A2-20;0))

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von PeterGri
07.01.2016, 19:55

Wow! Die Formel klappt einwandfrei. Super danke dir.

Ich habe noch weitere Berechnungen die ich mit Excel durchführen möchte. Hoffe es ist nicht unhöflich hier noch weiter zu fragen nach ähnlichen Formeln. Und zwar geht es um das Zählen der Stunden bei denen man (erneut) 25%, 40% und 50% Zuschlag bekommt:


(erneut) 25% - in der Zeit zwischen 4h und 6h. Dabei soll es wieder egal sein wann Arbeitsbeginn war


40% - in der Zeit zwischen 0h und 4h, aber nur wenn der Arbeitsbeginn vor 0h war. Außerdem kann hier auch wieder möglich sein, dass Arbeitsende zb 3h ist und als Ergebnis nur '3' rauskommt.


50% - den ganzen (Sonn-)tag. Als Bsp. von 0h-7h; von 7h-19h; 19h-0h sowie die ersten 4 Stunden des Folgetages wenn Arbeitsbeginn vor 0h war (Nacht von So auf Mo).


Hoffe das kann auch in Formeln ausgedrückt werden!

P.S.: Ich verwende das Uhrzeitformat

Gruß PeterGri

0

Die Formel kann so nicht funktionieren: S7 kann nicht gleichzeitig gleich 20 und größer 20 sein, daher greift die Wenn-Bedingung nie. Mit dem UND hast Du hinterlegt, dass beide Bedingungen erfüllt sein müssen. Größer/Gleich wird einfach durch S7>=20 ausgedrückt. Das kann dann zutreffend sein.

Das Ergebnis FALSCH wird angezeigt, weil Du keinen expliziten Wert angegeben hast, wenn die Bedingung nicht zutreffend ist (also den "sonst" Wert - Wenn ist ja so aufgebaut: Bedingung; Dann; Sonst)

Um eine Differenz von Uhrzeiten zu rechnen und dann in eine Zahl umzuwandeln, muss man etwas um die Ecke denken, da Excel zum Rechnen Uhrzeiten in Dezimalzahlen nimmt und nur bei der Anzeige 20:00 verwendet:

Wenn 24 Uhr das Maximum des Arbeitsendes ist, wäre es so möglich:
=WENN(S7>=20*0,04;(S7-"20:00")*24;0)

0,04 entspricht einer Stunde 

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Ninombre
07.01.2016, 17:19

Ich habe ehrlich gesagt nicht näher beachtet, wie sich S7 in Deinem Fall ergibt und was da drin stehen kann. Ist es 23.59, 24:00 oder auch über 0:00 hinaus? Dann müsste man die Fälle noch abbilden, die habe ich nicht betrachtet.

0
Kommentar von PeterGri
07.01.2016, 17:35

Hallo Ninombre,

das ist erstmal ein guter Hinweis im ersten Absatz! Und was du im 2ten Absatz sagst leuchtet auch ein.

Habe deine Formel ausprobier und leider das Ergebnis 0:00 bekommen. Und ja in meinem Beispiel sind die Endzeiten auch nach 24:00h. Sehr üblich ist die Arbeitszeit zwischen 19:00h und 07:00h.

Zum Verständnis nochmal kurze Beispiele:

19:00 bis 07:00 (Ergebnis: 4 Stunden bekommen 25% Zuschlag)

21:00 bis 07:00 (Ergebnis: 3 Stunden bekommen 25% Zuschlag)

17:00 bis 02:00 (Ergebnis: 4 Stunden bekommen 25% Zuschlag)

23:00 bis 05:00 (Ergebnis: 1 Stunde bekommt 25% Zuschlag)

0
Kommentar von DeeDee07
07.01.2016, 19:30

0,04 entspricht einer Stunde

Aber nur wenn sich die Erde etwas schneller dreht :)

(1/24 = 0,0416666...)

0

Hallo Peter,

probier mal folgende Formel aus:

=WENN(STUNDE(C14)>=20;WENN(STUNDE(C15)=0;24;STUNDE(C15))-STUNDE(C14);4)

C14=Arbeitsbeginn

C15=Arbeitszeitende

Die erste WENN-Schleife kümmert sich daraum, dass bei einem Arbeitszeitbeginn vor 20:00 maximal nur 4 rauskommt.

Die zweite WENN-Schleife macht aus 00:00 (das wird in der Regel aus einer Eingabe von 24:00 gemacht) entsprechend umgerechnet wird.

Ich hoffe die Antwort hilft dir weiter.

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von PeterGri
07.01.2016, 17:27

Bei deiner Formel bekomme ich das Ergebnis 96:00

Habe C14=19:00 und C15=07:00

0

Was möchtest Du wissen?