Wie berechne ich eine Summe über einen Monat, der nicht immer in der gleichen Spalte steht?

5 Antworten

Die Formel und das Beispiel kriege ich nicht zusammen, aber an die Stelle von [summebereich], also dritter Parameter von summewenn kannst Du bereich.verschieben setzen.

=SUMMEWENN(B7:B10;"Artikel 1";BEREICH.VERSCHIEBEN(C7:C10;0;VERGLEICH(D14;C5:K5;0)-1))

Die Funktion bereich.verschieben ist nicht ganz eingängig - ein Versuch der Erklärung:

Der Bereich C7:C10 kann sowohl hinsichtlich der Zeilen als auch der Spalten verschoben werden - man kann auch die Höhe und Breite reduzieren, aber das ist hier nicht notwendig. Im Grund reicht Dir ja aus, wenn man den Bereich über den die Summe gebildet wird, soweit nach rechts verschiebt (also die Spalten, dass der entsprechende Monat/Jahr ausgewertet wird. Das macht der VERGLEICH. Nochmal andersrum formuliert: Über VERGLEICH die Spaltenüberschrift K5 in deinem Bild in der Zeile der Rohdaten suchen und den Bereich entsprechend nach rechts verschieben.

Arbeite doch mit Summewennsstatt ein Vergleich ob der Artikel passt, machst du 2 Vergleiche ob der Artikel UND der Monat passt.

Alternativ kann man mittels BereichVerschieben die Spalte anpassen, oder über Indirekt die zu diesem Monat passende Spalte einsetzen...

Man müsste den Aufbau deiner Tabelle besser kennen.
Zudem wird mir eines so gar nicht klar aus deiner Frage:
"Wie bekomme ich es automatisch hin, dass im nächsten Monat die Summe
nicht mehr über F läuft sondern über G und die Summewenn wieder auf die
einzelnen Marken."


WOOO steht denn dieser nächste Monat? Auf einem neuen Blatt? in der nächsten Spalte? Unter dem vorherigem Monat?
Bilder sagen bekanntlich mehr als 1000 Worte.

Ich weiß gar nicht, wie ich zu meinem Beitrag noch ein Bild hinzufügen kann. Hab unten quasi nochmal einen Kommentar eingefügt mit einem Screenshot. Hilft das besser?

0
@Noga1981

kann man leider nicht nachträglich ranhängen, daher ist der Kommentar schon richtig so

0

Hallo,

puh... viel Text, bin etwas durcheinander. Ein Bild wäre hier glaube ich aussagekräftiger gewesen.

Aber wenn ich nicht ganz durcheinander bin, sollte SUMMEWENNS deine Lösung sein. Damit kannst du mehrere Bedingungen abfragen.

Sollte ich das fehlinterpretiert haben, wäre ich dann doch für einen Screenshot.

LG, Chris

Screenshot is online :-)

0

Was möchtest Du wissen?