Wie baue ich die Formel in Excel um?

...komplette Frage anzeigen

2 Antworten

So kannst du eine Tabelle von unten durchsuchen, so dass in deinem Fall das letzte passende Datum ausgegeben wird http://excelformeln.de/formeln.html?welcher=26

die Formel wäre dann

{=WENN(A1<>"";INDEX('Statusliste DHL'!C$1:C$1000;MAX('Statusliste DHL'!C$1:C$1000=A11)*ZEILE($1:$1000));"")}

(ungetestet)

Es ist eine Matrixformel, die mit Strg+Alt+Enter abgeschlossen wird, wordurch die {} erzeugt werden.

Die Bezugsstruktur erscheint mir aber recht eigenartig zu sein. In A1 steht das 1. Datum und in A11 der Kunde? Jedenfalls ist das in deiner Formel so.

Antwort bewerten Vielen Dank für Deine Bewertung
ReneSaince 15.01.2016, 15:46

=WENN(F11<>"";SVERWEIS(A11;'Statusliste DHL'!$B:$F;2;0);"")

Das war die Ursprungsformel. A1 habe ich nur genommen, weil ich von Spalte 1 und 2 gesprochen habe um es zu vereinfachen.

0

Das kannst du so lösen:

=INDEX('Statusliste DHL'!$B$4:$F$10;VERGLEICH(Tabelle1!A12;WENN('Statusliste DHL'!$C$4:$C$10<>Tabelle1!B12;'Statusliste DHL'!$B$4:$B$10);0);2)

sinngemäß, die größe der bereiche musst du natürlich selbst anpassen

Das ganze ist dann eine Arrayformel die mittelt Strg+Shift + Enter abgeschlossen werden muss.

Die Idee dahinter, Index und Vergleich sind lediglich eine erweiterte Kombination die Sverweis ersetzen. Dabei ist der Vergleich zusätzlich noch an eine Wenn Bedingung gekoppelt, nämlich das die Bestellung gesucht wird die nicht dem Tag der ersten bestellung entspricht.
Falls beide Bestellungen an einem Tag sein können, funktioniert der Lösungsweg natürlich nicht.
Weiterhin zeigt die Formel ein NV falls es keine 2. Bestellung gibt, das müsste man entsprechend Abfangen zB mittels der Funktion WennNV

Antwort bewerten Vielen Dank für Deine Bewertung

Was möchtest Du wissen?