Wenn Zelleninhalt mit "3D" anfängt dann anderen Wert nehmen

3 Antworten

=WENN(AC38="3D";AI38;AC38)

müsste in die Richtung gehen

Die Formel bezieht sich auf A1 und B1

=WENN(LINKS(B1;2)="3D";B1;A1)

=WENN(LINKS(AC38;2)="3D";AI38;AC38)

Willst du auch noch die Folgezeichen auf numerische Werte prüfen:

=WENN(UND(LINKS(AC38;2)="3D";LÄNGE(AC38=8);ISTZAHL(WERT(RECHTS(AC38;6))));AI38;AC38)
1

Excel - Negative zahlen Addieren bis Wert in Zelle = 0 ergibt

Hallo zusammen,

ich sitze gerade auf der Arbeit und muss eine Excelliste bearbeiten. Es ist eine Auflistung von Konsientnahmen. Anfang des Jahres war der Stand 0, dann wurden z..B. 10k geliefert, 26k, 25k, etc. Irgendwann wurden dann z.B. 50k entnommen. Der Kunde entnimmt FiFi (First In First Out, also was zuerst reingekommen ist wird auch zuerst entnommen)

Ich bin auf der Suche nach einer Formel die folgendes macht: Sie nimmt den ersten positiven Wert, sucht dann nach negativen werten und addiert sie alle zum positiven Wert bis dieser <=0 wird. (In dem Moment wo es null wird, ist die gelagerte Menge ja komplett entnommen.

Dann soll er das Datum der Lieferung minus dem Datum der Entnahme nehmen, damit habe ich dann die Verweildauer der Ware im Lager. Anschließend soll er mit der nächsten Zelle weiter machen.

Ist das irgendwie zu realisieren?

...zur Frage

Formel für lückenloses Auflisten einer Spalte in Excel 2007

Hallo,

ich habe folgende Situation Excel 2007

In der Spalte FE stehen Zahlen von der Zelle FE 1062 - FE 1562 in diesem Bereich stehen etwa 30 verschiedene Zahlen. D.h es gibt viele leere Zellen dazwischen.

Um das zu verhindern, hätte ich gerne eine Formel die die Zahlen lückenlos auflistet in die Spalte IB von Zelle IB 1062 - IB 1562.

Hier ist meine Formel wie ich sie mir überlegt habe:

{=WENN(ZEILE(A1)>ANZAHL2(A:A);"";INDEX(A:A;KKLEINSTE(WENN(A$1:A$1000<>"";ZEILE($1:$1000));ZEILE(A1))))}

Diese Formel funktioniert auch eigentlich. Aber nur wenn die Zahlen, welche sortiert werden sollen z.B in der Zelle A1 oder B1, C1.... stehen. Ich habe auch schon versucht einfach diese Formel auf die Spalte FE anzupassen, aber Excel zeigt dann nur in der Spalte IB leere Zellen an, also keine aufgelisteten Zahlen.

Kann mir jemand von euch helfen, damit die Formel richtig arbeitet ?

am besten gleich eine korrekte Formel hier reinstellen.

Gruß Danii358

...zur Frage

Was möchtest Du wissen?