WENN und UND Funktion in Excel?

... komplette Frage anzeigen

2 Antworten

Deine Formel sieht soweit gut aus. Wenn das Ergebnis trotzdem nicht dem Erwarteten entspricht, kannst du zum einen schauen, ob alle Zellen das gleiche Zahlenformat haben (Standard oder Zahl, zumindest nicht Text). Ansonsten kannst du im Menü Formeln, Formelüberwachung, Formel auswerten die Formel schrittweise berechnen lassen, vielleicht findest du dort den Fehler.

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Iamiam
19.09.2016, 18:14

Die Abfrage =istzahl(A1), =istzahl(A2) und =istzahl(A3) sollte weiterhelfen!

0

Die Formel sieht korrekt aus A1 ≤ A3 ≤ A3.

Ich kann mir höchstens vorstellen, dass ein Datentypproblem vorliegt. Sind alle drei Felder gefüllt? Sind alle drei Felder als Zahl formatiert? Kannst du mit den Werten rechnen? Funktioniert =A1+1 und =A2+1 und =A3+1?

Alternativ zu UND könntest du ein geschachteltes WENN probieren, um eventuell herausfinden zu können, an welcher Bedingung es scheitert.

Statt

=WENN(UND(Bed1;Bed2);"ok";"nicht ok")

kann du 

=WENN(Bed1;WENN(Bed2;"ok";"nicht ok 2");"nicht ok 1")
Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Suboptimierer
19.09.2016, 10:15

Was auch helfen könnte, ist das Echtzeitdebuggen. (Siehe DeeDee07)

Formeln → Formelüberwachung → Formelauswertung

0
Kommentar von Armsiii
19.09.2016, 10:16

Mit der abgeänderten Funktion hat er ein unterschreiten und überschreiten der Werte festgestellt und dementsprechend das "ok" und "nicht ok" ausgegeben.
Ich danke für die schnelle Hilfe.

1
Kommentar von Armsiii
19.09.2016, 10:25

ich prüfe das nocheinmal nach was mir die formelüberwachung ausgibt.

0

Was möchtest Du wissen?