Wenn-Und-Oder?

...komplette Frage anzeigen

4 Antworten

kann es sein, dass Dir diese einfache Lösung reicht?:

=G2&" "& H2&" "&wenn(F2="";"";i2)

in Worten: verkette immer G und H und füge dann, wenn in E was steht, i hinzu?

Das Eine Lizenz kannst du auch noch dranhängen, das bedingte drumrum nach dem gleichen Wenn-Schema.

Frag ggf zurück.

oder soll die Formel erkennen, dass "girl" ein "für Mädchen" verlangt und "boy" ein "für Jungen", ggf "men" ein vorangehendes "Männer-" wird und kein angehängtes "für Männer", analog  "Lady" die Vorsilben "Frauen-" setzt  und nicht "für Frauen" anhängt?

Das wäre ziemlich aufwändig (aber vorr. machbar)

Antwort bewerten Vielen Dank für Deine Bewertung
Iamiam 16.07.2017, 10:54

'Lizenz' -anhängen etwas genauer:

&Wenn(K2="";"";" (e. "&K2&")")

Da kannst Du dann auch andere Wörter übernehmen, der abgekürzte Artikel 'e.' stimmt immer. ansonsten " eine "&K2&")"

0
Iamiam 16.07.2017, 11:23
@Iamiam

Adressenkorrekturen:

natürlich nicht K2, sondern lt Deinem Screenshot AA2.

sowie Formel leicht verändert,  insgesamt also:

=G2&" "& F2&" "&wenn(E2="";"";i2)&Wenn(AA2="";"";" (e. "&AA2&")")

Spalte H wird überflüssig, wenn ich dich richtig verstanden habe. Es kann ja auf F zurückgegriffen werden. (Bin mir da nicht sicher, weil keine Alternativbeispiele vorhanden)

Leerzeichen: wenn Du die schon in den Zellen stehen hast, dann die Formel natürlich ohne &" "

0

So wie ich Dich verstehe, müsstest Du Dir eine Tabelle anlegen, die Dir alle Textilien auflistet, die geschlechtsspezifisch sind, also z.B Bluse, Kleid, Hemd usw..
Angenommen diese Liste ist in Tabelle1!A1:A100.
Dann in Deiner Liste vom Screenshot in Q2 diese Formel:

=WENN(ZÄHLENWENN(Tabelle1!A1:A100;H2)>0;G2&" "&H2;G2&" "&H2&" "&I2)

Habe ich Dich so richtig verstanden?

P.S.: Das mit der Lizenz in AA2 hatte ich übersehen, verstehe es aber auch nicht richtig.
Kannst Du da nochmal erläutern?

Antwort bewerten Vielen Dank für Deine Bewertung
Oubyi 14.07.2017, 15:02

P.S.: Vielleicht braucht auch nur AA2 angehängt zu werden, falls das leer bleibt, wenn keine Lizenz da ist?!:

=WENN(ZÄHLENWENN(Tabelle1!A1:A100;H2)>0;G2&" "&H2&" "&AA2;G2&" "&H2&" "&I2&" "&AA2)

0

Wir brauchen mal ein bisschen mehr Informationen zum Aufbau der Tabelle, ein Screenshoot sagt meist mehr eine Textwand ohne Absatz.

Antwort bewerten Vielen Dank für Deine Bewertung
TiRi001 14.07.2017, 09:41

So sieht meine Tabelle aus. In Zelle Q soll mein Wunsch stehen. Aber er muss halt Vorher Überprüfen: Was steht in Zelle C2, F2 und AA2.

0

Ich hoffe das hilft.

 - (Excel, Wenn und funktion, Neue Anfrage)
Antwort bewerten Vielen Dank für Deine Bewertung
Jackie251 14.07.2017, 09:55

Ja das hilft schonmal
zurück zu deiner Frage oben
"Kurz um: Ist der Artikel Geschlechtsspezifisch darf kein "für Mädchen" oder "für Jungen" dahinter stehen."

Das ist falsch beschrieben oder?
Wenn der Artikel geschlechtsspezifisch ist, dann soll doch eben gerade für Mädchen/Jungen dranstehen oder?

Da du nun eh schon in Hilfspalten die Einzelbezeichnungen rausgesucht hast, reich in Spalte Q doch ein

=G2&" "&H2&" "&I2

Wenn in Spalte I keine Geschlechtsbezeichnung steht - die Zelle also leer ist, dann wird doch auch keine Geschlechtsbezeichnung dran gehängt.
Ich verstehe noch nicht wozu du da eine Fallunterscheidung brauchst

1
TiRi001 14.07.2017, 10:11
@Jackie251

Wenn man eine Kleid oder Hemd hat ist klar, dass es für Jungen oder Mädchen ist.

Ist es aber eine Hose muss der Unterschied passiert. Da Die Hose durch ihren verschieden Schnittformen für ein Mädchen sein kann ODER für einen Jungen.

0
Oubyi 14.07.2017, 14:59
@Jackie251

Das ist falsch beschrieben oder?
Wenn der Artikel geschlechtsspezifisch ist, dann soll doch eben gerade für Mädchen/Jungen dranstehen oder?

Also DAS ist imho so richtig. Zumindest verstehe ich es so.
Wenn da "Kleid" steht, dann braucht man nicht den Zusatz "für Mädchen", das Kleider für Jungen eher die Ausnahme sind (:o).
Wenn da aber Hose steht, ist der Zusatz nötig.

0
Jackie251 14.07.2017, 18:19
@Oubyi

ja schon, aber wenn dort Kleid steht, dann sollte doch die Hilfspalte I schon gar nicht mehr "für Mädchen" beinhalten.
Die Zuordnung/Übersetzung der einzelnen Eigenschaften sollte in mit den Hilfsspalten schon abgeschlossen sein.

0
TiRi001 14.07.2017, 10:18

Noch mal Beispiele:

  • Kinder Kleid
  • Baby Kleid
  • T-Shirt für Jungen
  • T-Shirt für Mädchen
  • T-Shirt Star Wars
  • Baby T-Shirt Star Wars
0

Was möchtest Du wissen?