WENN-Funktion verweist auf Zelle welche ebenfalls eine Funktion entählt und als Wert dann "TRUE" an meine Wenn-Funktion übergibt (anstelle angezeigten Wert)?

... komplette Frage anzeigen

4 Antworten

Richtig verstanden habe ich nicht, was jeweils in Spalte A und B steht.

Ist die Formel tatsächlich in genau dieser Form hinterlegt wenn(A1=B1,ok,wrong)? Das kann in Excel so nicht stimmen.

Was meinst Du konkret damit, dass für die Spalte A ein TRUE übergeben wird? Wenn A1=B1 dann sollte doch true rauskommen, oder? Warum sollte ein angezeigter Wert übergeben werden in der Bedingung?

Antwort bewerten Vielen Dank für Deine Bewertung

Wenn du deutsche Funktionsnamen verwendest, musst du die Argumente mit Semikola ; trennen. Bei englischen mit Kommata ,

=WENN(A1=B1;"ok";"wrong")
=IF(A1=B1,"ok","wrong")

Wenn du das falsche Trennzeichen setzt, hast du nur das 1. Argument (die Prüfung) gesetzt. Die beiden anderen (dann, sonst) erhalten die Standardrückgabewerte TRUE und FALSE.

Obwohl, mit der Formel in der Frage dürfte es sogar eine Syntaxfehlermeldung geben.

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Maxchen85
17.11.2016, 22:21

Ja da hast du natürlich recht. Mein Fehler. Computer ist auf englisch gestellt ;). Aber ich habe das richtige Trennzeichen verwendet. Trotzdem danke für deine Antwort :)

0

Ich denke du musst denn SVerweiß so umstellen das er eine Zahl ausspuckt 

Antwort bewerten Vielen Dank für Deine Bewertung

Danke für die echt schnellen Antworten. Um meine Frage etwas genauer zu formulieren (Meine Formeln sich etwas komplexer, aber um das Problem darzustellen und ich konnte es auch so nachstellen in Excel):


       A      B

1:   10   10

2:   20    30

3:   40    40


=IF(A1=B1;"ok";"wrong")  -->Ergebnis: wrong


-->die Werte in A sind durch ein SVerweis aus einer anderen Tabelle.

-->Und wenn ich mir jetzt mit dem Formel-Editor die Formel angucken wird mir als Werte angezeigt für A1:True B1: 10


Da eure Antworten echt schnell kamen, muss ich den ersten Vorschlag erst einmal ausprobieren/durchdenken ;). Aber danke schon mal für diesen Tipp.


Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von DeeDee07
17.11.2016, 21:13

Haben die beiden Spalten A und B auch das gleiche Zellformat? (Text, Zahl,...)

0

Was möchtest Du wissen?