Wenn eine bestimmte Zeile einen Wert enthält, dann die komplette Spalte woanders angeben?

... komplette Frage anzeigen

3 Antworten

Ein ähnliches Problem habe ich hier schon gelöst (hoffe ich):
https://www.gutefrage.net/frage/aufzaehlung-excel-nach-namen?foundIn=list-answers-by-user#answer-188451280
Bezogen auf Deine Tabelle könnte das so aussehen:
Angenommen Die Monats-Formel steht in AD6 und folgende, also Spalte AD, dann diese Formel und drei Zellen nach rechts kopieren und dann alles soweit wie nötig nach unten kopieren:

{=WENNFEHLER(INDEX(AA$1:AA$1000;KKLEINSTE(WENN($AD$6:$AD$1000=1;ZEILE($AD$6:$AD$1000));ZEILE(A1)));"")}

**ACHTUNG!**
Das ist eine Matrixformel.
Das bedeutet: Die geschweiften Klammern {} NICHT mit eingeben, sondern die Eingabe der Formel NICHT mit ENTER abschließen, sondern mit:
STRG & SHIFT & ENTER (alle drei gleichzeitig).
DAS erzeugt die { } und macht die Formel zu einer Matrixformel.

Die 1 in der Formel ($AD$6:$AD$1000=1) für den Januar, kannst Du auch durch einen Zellbezug ersetzen.
Also z.B. durch
...$AD$6:$AD$1000=$AF$6...
und dann in die Zelle AF6 die Nummer für den Monat, also z.B. 1, schreiben.

Kommst Du klar?

P.S.: Ach ja, die Spalte, in der die Formel das Datum aus AC anzeigt musst Du nach dem Einfügen der Formeln noch mal als Datum formatieren, sonst wird Dir nur 42041 oder sowas angezeigt.


Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von bemerkenswert
05.01.2016, 13:01

#NAME? kommt dann leider bei raus. Glücklicher Weise ist die Monats-Formel in AD6, daher müsste das ja eigentlich so passen. Aber scheint nicht der Fall zu sein.

0

Wenn Dein gefragter Monat -egal. ob über Formel oder direkt eingegeben- in M2 steht (M für Monat), dann folgende Formel in zB M3:

Achtung: Dies ist eine Matrixformel! Die geschweiften {Klammern} NICHT miteingeben, sondern die Formel anstatt mit einfachem Enter mit der Kombination (gleichzeitig) Strg+Shift+Enter abschließen (nach jeder Neubearbeitung wieder!). Die {Klammern} entstehen dann automatisch.

Schreibtechnisch nimmst Du am besten die rechte Strg- und Umschalttaste, dann gehts mit einer Hand und lässt sich auch leichter merken! 

{=INDIREKT(ADRESSE(KKLEINSTE(WENNFEHLER(VERGLEICH($M$2&TEXT(ZEILE($C$1:$C$11);"0000000000");$C$1:$C$11&TEXT(ZEILE($C$1:$C$11);"0000000000");0);10^7);ZEILEN(M$3:M3));SPALTE(C$1)))}

Das gibt dir zunächst mal nur den Monat nochmals wieder. Du kannst diese Formel aber nach links, rechts  und nach unten kopieren, dann erhältst Du die entsprechenden Werte (nach Zeilen geordnet)

Du kannst auch M2:M3 auf ein anderes Blatt versetzen und/oder verschieben

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Iamiam
04.01.2016, 18:07

Da meine derzeitige Rechnerkrücke wegen eines Windows-Updates extrem langsam wurde, hab ich die AW schon mal unkorrigiert weggeschickt.

Du musst die 11 natürlich durch zB 1111 oder vllt auch 55555 etc ersetzen, A durch AA, B durch AB, C durch AC ersetzen.

Zur Erklärung der Formel:

Wenn mehrere/viele gleiche Nennungen individuell zu finden sein sollen, muss man sie unterscheidbar machen. Das geht in dem von Dir wahrscheinlich geforderten Umfang nur mit einer Matrixformel (kannst du dir so vorstellen, dass da im Arbeitsspeicher eine/mehrere Spalten angelegt werden, die die Formelzwischen-ergebnisse (hier Eintrag+Zeile) enthalten.

(Für Näheres empfehle ich  Peter Haserodt, gugl mal danach, wenn Dich die Möglichkeiten überzeugen)

Die Zelle mit dem Abfragemonat und die Basisformel kannst Du am besten gemeinsam- beliebig verschieben. Kopieren nach links hat nach 2 Spalten das Linit A$1 erreicht, bei AC gehts dementsprechend viel weiter..

Nach-unten-kopieren liefert Verwertbares, solange noch Einträge mit dem Suchargument zur Verfügung stehen, unterhalb gibts einen Fehler, das signalisiert: keine weitere Nennung.

Die Fehlermeldungen der Matrix (alle Einträge, die nicht der Monatszahl entsprechen) werden mittels Wennfehler durch eine große Zahl (größer als maximal mögliche Zeilenzahl) ersetzt.

Eine Besonderheit ist vllt noch das K-Argument in KKleinste. Das ist eine Laufzahl, die durch die Zeilenzahl des Bereichs der Basisformel bis zur Position der Formel gebildet wird, also von 1 -- n.

Falls Du noch Fragen hast, gib eine Bewertungab, damit ich was sehe und die Frage nochmals herhole.

viel Erfolg!

0

Nun wenn das Wort Monat zusätzlich dort stehen soll, dann vielleicht so.

=WENN(ISTLEER(AC6);"";"MONAT "& (AC6))

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von bemerkenswert
04.01.2016, 14:19

Nein, das hast du vielleicht missverstanden. Die Extrazeile sieht sowieso niemand, daher ist es egal, ob da "1" oder "Januar" steht. Mir geht es darum, dass wenn "1" in der Zeile vorhanden ist in dieser Extra-Spalte, dass es dann in einer weiteren Extraspalte mir die komplette Zeile "kopiert" bzw mir dort wiedergibt.

0

Was möchtest Du wissen?