Welche Formel brauch ich für Excel, dass es mir die Anzahl eines Wortes als Zahl gibt?

...komplette Frage anzeigen

3 Antworten

=ZÄHLENWENN($A$2:$AB$2;"Ja")

Danke fürs ☆

0

Wenn Du nur Zellen mit isoliertem Ja zählen willst, funktioniert die Formel von Oubyi. Hast Du aber Texte drin stehen wie "ich habs dir ja gesagt" oder "ich hab Ja gesagt", dann Musst Du die Abfrage zusammensetzen:
=ZÄHLENWENN($A$2:$AB$2;"Ja")+ZÄHLENWENN($A$2:$AB$2;"* Ja *")
(ja im Text als von Leerzeichen eingerahmtes Wort mit was davor und/oder dahinter).

es gibt aber auch noch andere Konstellationen: "Da bist Du ja!" oder "jawohl" oder "ja, freilich": dabei nützt es nichts, "*ja*" zu zählen, denn das erfasst auch Wörter wie Jahr, Jaguar oder Djakarta. Auch wenn ja zweimal vorkommt in einer Zelle, wird nur 1 wiedergegeben. Eine manuelle Auswertung ist hier unumgänglich, aber man kann wenigstens eine Hinweiszelle einbauen, die Formel:
=ZÄHLENWENN($A$2:$AB$2;"*Ja*")-ZÄHLENWENN($A$2:$AB$2;"Ja")- ZÄHLENWENN($A$2:$AB$2;"* Ja *")
ergibt >0, wenn ja in anderer Form als einzeln oder als isoliertes Wort auftritt. Zweimal ja in einer Zelle wird allerdings auch da nicht erfasst, das ginge mit dem Suchargument "*ja*ja*" in Zählenwenn. Und wenn dreimal?... (dann muss man sich ALLE Zweimal noch einmal anschauen;-(
Wenn Du alle Findungen zusammenzählst und die Zahl notierst, sodann mit Suchen und ersetzen im gesamten Bereich (ohne Formeln) "ja" durch "X%Y" ersetzt und die Meldung aufmerksam liest, dann kannst du daraus entnehmen, wie viele Ersetzungen insgesamt vorgenommen wurden. Hinterher sofort rückgängig machen (zur Not rückwärts ersetzen, dashalb die komische Zeichenfolge, aber dabei wird die Differenzierung zwischen Groß-und Kleinschreibung aufgehoben).
Das alles rentiert sich nur bei längeren Textbausteinen. Und mit immer steigender Komplexität ließe sich durchaus noch mehr machen [zB mit der Formel
Länge(Zellinhalt)-Länge(Wechseln(Zellinhalt, "ja" gegen zB æ ) mehrfach verschachtelnd wiederholt], lohnt aber meist nicht.

Das mit Wechseln zählt in Einzelzellen die Anzahl der Vorkommen einer Zeichenfolge, und/aber unterscheidet zwischen Groß- und Kleinschreibung. Folgende Formel wechselt max. 3 "ja" plus max. 3 "Ja" mit jeweils zwei Zeichen gegen ein Einzelzeichen aus. Differenz: je 1 Zeichen.
=LÄNGE(A1)-LÄNGE(WECHSELN(WECHSELN(WECHSELN( WECHSELN(WECHSELN(WECHSELN(A1;"ja";"æ";1);"ja";"æ";1) ;"ja";"æ";1);"Ja";"æ";1);"Ja";"æ";1);"Ja";"æ";1))

Setzt Du eine ganze Zeile dieser Formeln unter die auszuwertenden Zellen, kannst Du die Zeile summieren und damit ALLE ja un ja zusammenzählen (bis max. j3 3 pro Zelle). Die Einschränkungen der Hauptantwort gelten allerdings auch hier: Jahr und Jaguar werden als Ja gezählt, Djakarta als ja.

0

von B2 bis AB2

Du meinst von A2 bis B2? Wenn ja, dann ist das der Code:

=ZÄHLENWENN($A$2:$B$2;"Ja")

Den musst du in eine beliebige leere Zelle kopieren.

Ich denke, gegen A2:AB2 ist nichts zu sagen!
Oder?

0

Was möchtest Du wissen?