Welche Excel Formel kann den Inhalt einer Zelle bestimmen, ohne vorherige Leerzellen zu berücksichtigen?

... komplette Frage anzeigen

3 Antworten

Nur kann die Anzahl der Leerzeilen variieren.

Das ist ein Problem.
Woher soll Excel wissen, ob die nächst Zelle eine Leerzelle sein soll, oder ob dort die nächste Zahl stehen soll?
Ich mache Dir mal einen Vorschlag (siehe auch meinen Screenshot):
Du machst in der Spalte B jeweils in der Zeile, wo A leer bleiben soll ein x.
Dann schreibst Du in A1 diese Formel und kopierst sie runter, soweit wie nötig:

=WENN(B1="x";"";INDEX({5;9;2};REST(ANZAHLLEEREZELLEN($B$1:B1)-1;3)+1))

Oder kann man die Leerzellen anders bestimmen?
Dann beschreibe das bitte genau.

P.S.: Die Formel ist etwas komplex.
Vielleicht fällt ja noch jemandem etwas einfacheres ein?

Antwort bewerten Vielen Dank für Deine Bewertung

 A9 könnte doch selbst wieder leer sein. o.O

Suchst du einfach nur das nächste Folgeglied? Das ist

=WENN(ZÄHLENWENN(A:A;5)>ZÄHLENWENN(A:A;9);9;WENN(ZÄHLENWENN(A:A;9)>ZÄHLENWENN(A:A;2);2;5))

Willst du die Formel in A9 einfügen, solltest du A:A durch $A$1:A8 ersetzen.

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Suboptimierer
02.04.2016, 09:39

Alternative:

=WAHL(REST(ANZAHL(A:A);3)+1;5;9;2)
2

Wie lautet die Frage? Bildungsgesetz?

Antwort bewerten Vielen Dank für Deine Bewertung

Was möchtest Du wissen?