Was stimmt mit dieser Excel Funktion nicht?

... komplette Frage anzeigen

3 Antworten

pro Forma, bei soviel Aufwand wäre schon eine Hilfreichste fällig!

Antwort bewerten Vielen Dank für Deine Bewertung

so, jetzt hab ich doch auch noch was beizutragen: Falls PSBnn am Anfang steht (hier nur für 3 Parameter ausgearbeitet):

=WENN(
NICHT(ISTNV(
VERGLEICH(F1;{"PSB10";"PSB12";"PSB14"})
))*
VERGLEICH(F1;{"PSB10";"PSB12";"PSB14"})*
VERGLEICH(F1;{"PSB10";"PSB12";"PSB14"})
;F1;"-")

Auch kaum länger wäre ein Ansatz, wie er in dem Deinigen und anderen Antworten ähnlich schon umrissen wurde -nimm lieber diesen, der ist sicherer und auch noch übersichtlicher:

=WENN(
NICHT(ISTFEHLER(SUCHEN("PSB10";F1;1)))+
NICHT(ISTFEHLER(SUCHEN("PSB12";F1;1)))+
NICHT(ISTFEHLER(SUCHEN("PSB14";F1;1)));F1;0)

Das + steht ja für ODER, das Nicht() unterdrückt die Fehler, und Suchen unterscheidet NICHT zwischen Groß/klein-Schreibung (soll das geschehen, dann FINDEN(gleiche Syntax).

Da das Wenn unverschachtelt ist, sollte es bzgl. der Klammern einfacher sein.

Mit Wennfehler(....;0) müsste es auch gehen, hab ich aber jetzt nicht mehr ausprobiert.

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von iMPerFekTioN
19.05.2017, 08:29

WENNFEHLER müsste doch (m.e.a.) ungefähr so aussehen:

=WENN(WENNFEHLER(FINDEN("PSB-10";F8;1);0)>0;"PSB 10";
WENN(WENNFEHLER(FINDEN("PSB-12";F8;1);0)>0;"PSB 14"
WENN(WENNFEHLER(FINDEN("PSB-14";F8;1);0)>0;"PSB 12";
...
...
1

Hallo,

du hast eine Klammer zu viel ;)

=WENN(ISTFEHLER(Finden("PSB-10";F1)>0);"PSB 
10";WENN((ISTFEHLER(FINDEN("PSB-12";F1)>0);"PSB
14";WENN(ISTFEHLER(FINDEN("PSB-14";F1)>0);"PSB
12";WENN(ISTFEHLER(FINDEN("PSB-16";F1)>0);"PSB
16";WENN(ISTFEHLER(FINDEN("PSB-20";F1)>0);"PSB
20";WENN(ISTFEHLER(FINDEN("PSB-20";F1)>0);"PSB
20";WENN(ISTFEHLER(FINDEN("PSB-25";F1)>0);"PSB 25";0)))))))

Hab sie dir mal FETT markiert ;)

So sollte das eigentlich gehen:

=WENN(ISTFEHLER(FINDEN("PSB-10";F1;1)>0);"PSB 10";WENN(ISTFEHLER(FINDEN("PSB-12";F1;1)>0);"PSB 14";WENN(ISTFEHLER(FINDEN("PSB-14";F1)>0);"PSB 12";WENN(ISTFEHLER(FINDEN("PSB-16";F1)>0);"PSB 16";WENN(ISTFEHLER(FINDEN("PSB-20";F1)>0);"PSB 20";WENN(ISTFEHLER(FINDEN("PSB-20";F1)>0);"PSB 20";WENN(ISTFEHLER(FINDEN("PSB-25";F1)>0);"PSB 25";0)))))))

Grüße,


iMPerFekTioN


P.s. Was genau willst du denn bitte mit der Formel erreichen? o.O Kannst du das bitte etwas genauer erklären, ich werde nämlich nicht schlau aus dieser Anordnung :o

Mit dem Wissen was du erreichen willst, können dir die Profis hier bestimmt helfen ;)

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von ITJulianexe
18.05.2017, 10:30

Das hat schonmal funktioniert, die Formel stimmt trzd. nicht :/

1
Kommentar von ITJulianexe
18.05.2017, 10:34

Also was ich möchte: 

Ich habe hier vor mir eine Einfache Exceldatenbank (Die sich aktualisiert je nach Informationen, über sap bzw AX 2006), diese DB sendet mir in Excel eine Tabelle mit Informationen in Spalte F wie "PSB-12 1892/192/129" jetzt möchte ich per Wenn funktion in eine andere Spalte ( in dem fall eigentlich egal welche) per Finden funktion herrausbekommen, was das für ein (sogenantes) "PSB" ist. Also brauche ich eine Abfrage, die ermittelt was in der spalte steht, und diese Info dann in einer bestimmten Zelle ausgibt.

1

Was möchtest Du wissen?