Was ist ein relativer und was ist ein absoluter Bezug?

2 Antworten

Ein absoluter Bezug bezieht sich immer auf den gleichen Wert (zum Beispiel der Zahl 20, oder im Excel zur Zelle A1). Ein relativer Bezug bezieht sich auf eine Variable. Da kann 20 zu 21, 22, etc. werden.
Beim Excel, wie schon gesagt, wird das so dargestellt: A1 ist ein relativer Bezug. z.B: =SUMME(A1) $A$1 ist ein absoluter Bezug. =SUMME($A$1) Den Unterschied erkennst Du, wenn Du mit der Maus an der Ecke rechts unten ziehst: Beim relativen Bezug ändert sich die Quell-Zelle, beim absoluten Bezug nicht.

Vielleicht wird es am Beispiel von Excel klarer. Ein absoluter Bezug (z.B. $A$1) bleibt beim Kopieren oder Verschieben einer Formel immer gleich. Ein relativer Bezug (A1) würde sich "mitverschieben". Wenn also die Formel heißt A1+B1 und man verschiebt die um eine Zeile, wird bei einem relativen Bezug A2+B2 draus. Beim absoluten bleibt es bei A1+B2 (gehören dann eigentlich wieder die $-Zeichen dazu, was aber Excel spezifisch ist).

Was möchtest Du wissen?