Was für eine Excel-Formel kann zwei Zellen (B und C) verrechnen, wenn in Zelle A ein bestimmter Text steht?

... komplette Frage anzeigen

2 Antworten

Als Matrixformel
=SUMME((A1:A9="a")*(B1:B9*10)^(C1:C9))

nach der Eingabe mit STRG+SHIFT+ENTER abschließen, dann bilden sich noch { } um die Formel

=SUMMENPRODUKT((A1:A9="a")*(B1:B9*10)^(C1:C9)) ginge auch

Edit: Was auch Suboptimierer ja schon beschrieben hat

Antwort bewerten Vielen Dank für Deine Bewertung

Summier doch einfach über die Spalte E: =SUMME(E1:E9)

Ohne Hilfsspalte sähe das so aus: =SUMMENPRODUKT((A1:A9="a")*(B1:B9)*10^(ZEILE(A1:A9)-1))

Antwort bewerten Vielen Dank für Deine Bewertung

Was möchtest Du wissen?