2 Antworten

Hast du denn das JRE auch in der richtigen Bitversion bei dir installiert?

Ja, mein Betriebssystem und meine JRE Version sind beide 64 Bit basiert.

0

Warum Eclipse?

IntelliJ ist viel moderner, ausgereifter, funktionsreicher, weniger fehleranfällig usw.

Ja, ich weiß, hab ich auch eigentlich als ide. Ich muss jedoch an einem Projekt arbeiten was nur als eclipse Projekt vorhanden ist...

0
@paulderpupser

Ich kenne mich da nicht aus, aber mir wurde gesagt, dass das ein eclipse-Projekt ist. Und ich bekomme eine Fehlermeldung wenn ich sie in IntelliJ öffnen will...

0

Hauptklasse konnte nicht gefunden werden. java.lang.ClassNotFoundException - Java?

Hallo liebe Community,

ich habe ein Problem mit dem Kompilierungsvorgang bei Java. Seitdem ich Eclipse neu installiert habe und Java 10 heruntergeladen habe, kommt bei mir immer eine Fehlermeldung.

Diese lautet:

Fehler: Hauptklasse buergermeister konnte nicht gefunden oder geladen werden
Ursache: java.lang.ClassNotFoundException: buergermeister

Nachdem ich den Fehler gegoogelt habe kam nur sowas raus wie deine Umgebungsvariablen sind falsch gesetzt. Oder ich muss die JRE System Library einfügen. Aber an diesen Fehlern liegt es nicht. Es muss an Eclipse liegen, weil wenn ich die Datei in cmd mit dem Befehl "javac" kompiliere und dann mit "java" ausführe funktioniert das Programm.

Ich hoffe ihr könnt mir helfen, weil ich möchte nicht für immer mit cmd und Notepad meine Programme entwickeln.

Euch einen schönen Dienstag noch (:

...zur Frage

Java Eclipse installieren?

Hallo zusammen, wie bekomme ich diese scheeeeeisse zum laufen??? ich bin bei weitem kein Laie was PCs angeht aber diese scheeeeeisse lässt sich nicht starten. Egal was ich mache es kommt IMMER eine andere Fehlermeldung. Es handelt sich um ein nagelneues Notebook und ich habe bereits Version 8 und 11 von Java installiert aber es passiert absolut gar nichts. Gibt es irgendeinen beschissenen Trick um den Müll zum laufen zu bekommen? Aktuell ghet der scheeeeiss direkt im Edge Browser auf folgende Seite:

https://download.eclipse.org/oomph/jre/index-handler.php?vm=1_1_7_0_64_0&pn=Eclipse%20Installer&pu=http://wiki.eclipse.org/Eclipse_Installer&pi=http://download.eclipse.org/oomph/jre/128x128.png

finde keine Lösung und bin kurz davor meinen Laptop gegen die Wand zu werfen.

...zur Frage

Wie kann man eclipse installieren?

Ich habe mir vorgenommen eine "richtige" Programmiersprache zu lernen. Nach ein wenig Theorie wollte ich mich in der Praxis üben. Die Installation von Java(JDK1.8.0, JRE1.8.0) hat super funktioniert. Doch Eclipse macht Probleme!

Als erstes habe ich mir ein Package heruntergeladen(http://www.eclipse.org/downloads/packages/eclipse-ide-java-ee-developers/neon2) aber wenn ich die .exe starte kommt nur eine Fehlermeldung(siehe Bild), auch nach mehrfachen googeln und neuinstallieren konnte ich das Problem nicht lösen.

Dann hab ich mir das "normale" eclipse(https://www.eclipse.org/downloads/download.php?file=/oomph/epp/neon/R2a/eclipse-inst-win64.exe) heruntergeladen, aber wenn ich dort den Installer öffne passiert nichts.

Ich habe beides als Administrator ausgeführt und meinen PC habe ich auch schon neu gestartet. Ich habe einen Windows 7 PC mit 64bit

Danke im Voraus LG ysz0507

...zur Frage

Minecraft geht nicht trotz neuer java version, was soll ich machen?

Ich habe die neuste version von Minecraft und von java und habe ganz normales minecraft, also kein OptFine oder Labymod oder Forge an(eigentlich schon aber um zu testen ob es daran liegt, hatte ich es aus)und es kam das \ / oder es startet gar nicht, Hilfe, danke.

Verwendung: javaw [-options] class [args...] (zur Ausführung einer Klasse) oder javaw [-options] -jar jarfile [args...] (zur Ausführung einer JAR-Datei) wobei options Folgendes umfasst: -d32 Verwendet ein 32-Bit-Datenmodell, sofern verfügbar -d64 Verwendet ein 64-Bit-Datenmodell, sofern verfügbar -server zur Auswahl der "server" VM Die Standard-VM ist server.

-cp <Klassensuchpfad von Verzeichnissen und ZIP-/JAR-Dateien>
-classpath <Klassensuchpfad von Verzeichnissen und ZIP-/JAR-Dateien>
              Eine durch ; getrennte Liste mit Verzeichnissen, JAR-Archiven
              und ZIP-Archiven zur Suche nach Klassendateien.
-D<name>=<value>
              Legt eine Systemeigenschaft fest
-verbose:[class|gc|jni]
              Aktiviert die Verbose-Ausgabe
-version      Druckt Produktversion und beendet das Programm
-version:<value>
              Erfordert die angegebene Version zur Ausführung
-showversion  Druckt Produktversion und fährt fort
-jre-restrict-search | -no-jre-restrict-search
              Bezieht private JREs des Benutzers in Versionssuche ein bzw. schließt sie aus
-? -help      Druckt diese Hilfemeldung
-X            Druckt Hilfe zu Nicht-Standardoptionen
-ea[:<packagename>...|:<classname>]
-enableassertions[:<packagename>...|:<classname>]
              Aktiviert Assertionen mit angegebener Granularität
-da[:<packagename>...|:<classname>]
-disableassertions[:<packagename>...|:<classname>]
              Deaktiviert Assertionen mit angegebener Granularität
-esa | -enablesystemassertions
              Aktiviert Systemassertionen
-dsa | -disablesystemassertions
              Deaktiviert Systemassertionen
-agentlib:<libname>[=<options>]
              Lädt native Agent Library <libname>, z.B. -agentlib:hprof
              siehe auch -agentlib:jdwp=help und -agentlib:hprof=help
-agentpath:<pathname>[=<options>]
              Lädt native Agent Library nach vollem Pfadnamen
-javaagent:<jarpath>[=<options>]
              Lädt Java-Programmiersprachen-Agent, siehe java.lang.instrument
-splash:<imagepath>
              Zeigt Startbildschirm mit angegebenem Bild

Weitere Einzelheiten finden Sie unter http://www.oracle.com/technetwork/java/javase/documentation/index.html Java HotSpot(TM) 64-Bit Server VM warning: Using incremental CMS is deprecated and will likely be removed in a future release

...zur Frage

Minecraft Multiplayer (Online)Fehlermeldung?

Ich bin kein Deutsch Genie also bitte ich das zu Entschuldigen. :)

Ich habe mir gestern Minecraft gekauft und wollte direkt auf Servern Bedwars zocken. 1 Minute später kurz bevor es began bekam ich eine Fehlermeldung.

Hier auf Deutsch: # Ein schwerwiegender Fehler wurde von der Java Runtime Environment festgestellt: # # EXCEPTION_ACCESS_VIOLATION (0xc0000005) am pc = 0x000000001b7447a0, pid = 4508, tid = 3272 # # JRE-Version: Java (TM) SE Runtime Environment (8.0_25-b18) (build 1.8.0_25-b18) # Java VM: Java HotSpot (TM) 64-Bit-Server-VM (25.25-b02 gemischten Modus windows-amd64 Druck oops) # Problematische Rahmen: # C [ig7icd64.dll + 0x1547a0] # # Fehler beim Core Dump zu schreiben. Minidumps werden nicht standardmäßig auf den Client-Versionen von Windows aktiviert # # Ein Fehler Report-Datei mit mehr Informationen gespeichert als: # C: \ Users \ Paul \ AppData \ Roaming \ .minecraft \ hs_err_pid4508.log # # Wenn Sie möchten, um einen Fehlerbericht einreichen, besuchen Sie bitte: # Http://bugreport.sun.com/bugreport/crash.jsp # Der Absturz passiert außerhalb der Java Virtual Machine in nativen Code. # Siehe problematischen Rahmen für, wo die Fehler zu melden. # AL lib: (EE) alc_cleanup: 1 Gerät nicht geschlossen Java HotSpot (TM) 64-Bit-Server VM WARNUNG: inkrementelle CMS ist veraltet und wird wahrscheinlich in einem zukünftigen Release entfernt

(Sorry wegen den format ging nich anders)

Ja und nun kommt ihr Profi ins Spiel könnt ihr mir bitte Helfen? :( Ich würde Minecraft so gerne Spielen doch das hier macht mir einen Strich durch die Rechnung

...zur Frage

Minecraft fehlermeldung:AL lib: (EE) alc_cleanup: 1 device not closed Java HotSpot(TM) 64-Bit Server VM warning: Using incremental CMS is deprecated and will l?

Sobald ich auf einen Minecraft Server gehe, mit dem LabyMod oder Optifine stürzt nach einigen Sekunden Minecraft ab und es kommt eine Fehlermeldung.

Die Fehlermeldung:

A fatal error has been detected by the Java Runtime Environment: #

EXCEPTION_ACCESS_VIOLATION (0xc0000005) at pc=0x00007ffbc90f3033, pid=6392, tid=4940

#

JRE version: Java(TM) SE Runtime Environment (8.0_25-b18) (build 1.8.0_25-b18)

Java VM: Java HotSpot(TM) 64-Bit Server VM (25.25-b02 mixed mode windows-amd64 compressed oops)

Problematic frame:

C [ig4icd64.dll+0x43033]

#

Failed to write core dump. Minidumps are not enabled by default on client versions of Windows

#

An error report file with more information is saved as:

C:\Users\PC\AppData\Roaming.minecraft\hs_err_pid6392.log

#

If you would like to submit a bug report, please visit:

http://bugreport.sun.com/bugreport/crash.jsp

The crash happened outside the Java Virtual Machine in native code.

See problematic frame for where to report the bug.

# AL lib: (EE) alc_cleanup: 1 device not closed Java HotSpot(TM) 64-Bit Server VM warning: Using incremental CMS is deprecated and will likely be removed in a future release

...zur Frage

Was möchtest Du wissen?