Warum erzeugt mein WBB-Forum nach dem Wechsel der PHP-Version nur noch einen Internen Serverfehler (500)?

3 Antworten

Viele Provider bieten im Admin-Bereich der Webspace-Pakete die Option, alle Verzeichnisrechte neu setzen zu lassen. Ich habe bei all-inkl meine Homepage www.trancefish.de auf PHP7 über CGI gestellt und ähnliche Probleme gehabt.

Ich habe im Kundenadmin-Bereich die Rechte neu schreiben lassen (nicht über FTP, sondern tatsächlich den Owner geändert) - Danach ging es wieder

Kundenadminbereich - (Server, Programmierung, Forum)

Sehr geil. :-) Die Erwähnung "CGI" brachte die Lösung. Ich habe den PHP-Modus mal von "CGI" auf "FastCGI + opcache" umgestellt und es läuft damit wieder (warum auch immer). Die Forensoftware ist zwar sehr veraltet und müsste ausgetauscht werden, aber vorübergehend kann ich es wieder nutzen, bis ich Zeit dafür habe. DANKE!

0

Liegt wohl daran, dass diese Forensoftware echt richtig, richtig alt ist. Statt hier auf Frickellösungen zu setzen wäre es mMn sinnvoller, sich nach einer Alternative umzuschauen.

Update eines Forums mit dem alten phpBB 3.0.10?

Hallo!

Ich betreibe ein phpBB-Forum, welches momentan noch auf der Version 3.0.10 läuft. Leider stellt mein Webspace-Anbieter die alten PHP-Versionen ein und unter den neueren Versionen wie PHP 5.6 läuft das Forum nicht ordnungsgemäß.

Leider reichen die automatischen Updatepakete auf der deutschsprachigen Seite nicht bis zu meiner Version zurück. Ich bin jetzt gerade ein bisschen überfordert, weil ich mich auch nicht so gut damit auskenne.

Wie kann ich denn mein Forum mit allen Benutzern, Beiträgen etc. dennoch auf die neue Version updaten? Oder kann ich mit Hilfe eines Datenbank-Backups ein ganz neues und aktuelles phpBB-Forum mit den alten Inhalten füllen?

Danke im Voraus!

Grüße!

...zur Frage

Wie kann man die PHP Version eines Freenet Servers ändern?

Ich habe einen Freenet Server, auf dem ich Joomla! 3 installiert habe. Dafür benötige ich jedoch PHP Version 5.3 oder höher. In den Servereinstellungen bei Freenet wird mir angezeigt, dass der Server momentan PHP Version 5.2.3 nutzt. Dahinter kann ich weitere Versionen auswählen. Hier sind aber nur Versionen unter 5.3 aufgelistet. Gibt es irgendeine Möglichkeit eine neuere PHP Version (z.B. 7.1.6) zu installieren? Danke für eure Antworten!

...zur Frage

WBB 4 (Woltlab Burning Board 4) Probleme

Hallo,

Ich habe mir vor kurzem eine Domain und einen Webspace bei Nitrado geholt, und will darauf WBB4 installieren. Das Problem ist, wir möchten es so einstellen, das es direkt auf dem Forum umgeleitet wird. Wir geben bei dem Pfad /upload/ ein, trotzdem wird uns das Hauptverzeichnis, also / angezeigt. Dann hatten wir versucht es auf / zu installieren, also direkt auf dem Hauptverzeichnis. Dann kommt ein PHP Fehler.

Was soll ich machen?

Gruss

...zur Frage

Woltlab Burning Board Fehler?

Hallo, ich wollte eben Woltlab Burning Board V3.1.7 (WBB) installieren. Leider jedoch zeigt er mir beim Versuch die install.php aufzurufen nur folgenden Fehler an:

Fatal error: PHP error in file /tmp/fdd0122c_TemplatePluginPrefilterLang.class.php (30): preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead
Information:
error message: PHP error in file /tmp/fdd0122c_TemplatePluginPrefilterLang.class.php (30): preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead
error code: 0
file: /var/www/vhosts/gpmc-minecraft.de/home/forum/install.php (205)
php version: 5.5.38
wcf version: 1.1.9 (Tempest)
date: Thu, 26 Jan 2017 14:41:11 +0000
request: /forum/install.php
referer: <a href="http://gpmc-minecraft.de/forum/test.php">http://gpmc-minecraft.de/forum/test.php</a>
Stacktrace:
#0 [internal function]: handleError(8192, 'preg_replace():...', '/tmp/fdd0122c_T...', 30, Array)
#1 /tmp/fdd0122c_TemplatePluginPrefilterLang.class.php(30): preg_replace('~\\{lang\\}([\\w\\....', 'WCF::getLanguag...', '{$setupPackageN...')
#2 /tmp/fdd0122c_TemplateScriptingCompiler.class.php(1298): TemplatePluginPrefilterLang->execute('{$setupPackageN...', Object(TemplateScriptingCompiler))
#3 /tmp/fdd0122c_TemplateScriptingCompiler.class.php(87): TemplateScriptingCompiler->applyPrefilters('{$setupPackageN...')
#4 /tmp/fdd0122c_SetupLanguage.class.php(80): TemplateScriptingCompiler->compileString('wcf.global.page...', '{$setupPackageN...')
#5 /tmp/fdd0122c_WCFSetup.class.php(59): SetupLanguage->loadLanguage()
#6 /var/www/vhosts/gpmc-minecraft.de/home/forum/install.php(750): WCFSetup->__construct()

Oder als Bild: http://www.bilder-upload.eu/upload/008297-1485442171.png

Ich hoffe hier kann mir jemand sagen wo der Fehler ist (Bei WBB 3.1.6 kommt der gleiche Error).

MFG

...zur Frage

mysql_connect Datenbank Probleme oder PHP_ROOT Provider Telekom?

Hallo,

ich habe Problem ich habe damals eine Internet seite gekauft und sie ging auch da aber der Provider nicht mehr gibst habe ich noch die Scrips usw.. nun weiß ich nicht mehr weiter ich möchte meine Browsergame24.eu seite zum laufen kriegen

die Datenbank ist auch veraltet von 5.3 ich habe jetzt 7.0 oder 5.6 dass kann ich auswählen.

ich habe folgende daten:

<?php

$link = mysql_connect(...) or die ("keine sql Verbindung");

mysql_select_db("[Datenbankname aus Datenschutzgründen entfernt]") or die ("keine sql Datenbank gefunden");

define("PHP_ROOT","/kunden/123456789/game/");

was kommt da hin? bei der nummer 123456789???

include_once('de-lang.php'); // language file

$settings_limitstat = "100"; //Anzahl der Display-Klick-tracker Links auf Statistik-Seite

$settings_domainurl='http://www.browsergame24.eu/'; // bei / am Ende

ich habe den Provider Telekom

Serveradresse: hosting.telekom.de

Benutzername: @browsergame24.homepage.t-online.de

Datenbank: [Datenbankname aus Datenschutzgründen entfernt]

WEBDAV browsergame24.dav.telekom.de

wer helfen kann ware es super

...zur Frage

PHP-Version einfach ändern?

Einen wunderschönen Guten Morgen,

ich befürchte zwar, dass die Profis unter Euch jetzt entweder die Augen verdrehen oder die Haare raufen obgleich meiner "dummen" Frage, aber ich hoffe, ihr könnt mir dennoch helfen.

Ich habe auf meinem Webspace (kein kostenloser) sowohl ein Forum als auch eine friendica-Instanz laufen, die beide mit der voreingestellten PHP-Version 5.6.33 by OS Vendor - PHP ausführen als FastCGI-Anwendung von Apache bedient (das sind zumindest die Angaben, die ich bei der PLESK-Oberfläche gefunden habe).

Dann wollte ich gestern noch ein anderes Programm aufspielen (GNU/Social), was aber bei der Installation zu folgender Fehlermeldung führte:

Cannot load required extension:
|intl|

Please fix the above stated problems and refresh this page to continue 
installing.

Eine Anfrage bei meinem Webspaceanbieter ergab, dass dieses Problem damit gelöst wird, dass man auf PHP-Version 7 wechselt.
Geht das einfach so, dass ich schlichtweg auf der PLESK-Oberfläche von der 5.6.33 auf eine PHP 7-Version wechsele (sprich dieses im DropDownmenue einstelle) oder laufe ich damit Gefahr, dass die beiden anderen Programme (Forum und friendica-Instanz) damit plötzlich nicht mehr funktionieren?

Für die Antworten bedanke ich mich artig im Voraus

GLG

Tichuspieler


...zur Frage

Was möchtest Du wissen?