Verschachtelte Wenn-Funktion

... komplette Frage anzeigen

10 Antworten

Die Hauptsache ist doch eigentlich, dass du es kannst. Egal wie, hauptsache du kommst auf die richtige Lösung.

Hier trotzdem der Lösungsweg, wenn man von unten anfängt:

=WENNI(G8>80000;"10%";SI(G7<=80000;"7%";SI(G7<=50000;"5%";"2%")))

Natürlich muss dann in G8, der Wert stehe, von dem Excel das rechnen soll. Hoffe ich konnte dir helfen.

Antwort bewerten Vielen Dank für Deine Bewertung

lena2611 29.10.2012, 11:17

Si musst du durch wenn ersetzen, sorry bin in Frankreich ;)

0

Du kannst natürlich nicht mit <= 80.000€ anfangen, weil darunter auch die 10.000er fallen, die eigentlich zu <= 20.000€ gehören.
Du könntest aber abfragen:

Wenn >= 80.000, dann..., sonst wenn > 50.000, dann..., sonst wenn > 20.000, dann..., sonst...

Antwort bewerten Vielen Dank für Deine Bewertung

Zeige doch mal, wie Du das hinbekommst, wenn Du mit dem kleinsten Betrag anfängst.
ICH - und wohl auch Dein Lehrer - würde das so machen:

=WENN(A1>80000;A1*0,1;WENN(A1>50000;A1*0,07;WENN(A1>20000;A1*0,05;A1*0,02)))

Antwort bewerten Vielen Dank für Deine Bewertung

Poste doch mal Deine Formel. Dann haben wir die Zellbezüge und das "Umdrehen" sollte eigentlich ein Leichtes sein. Einfach die "Äste" austauschen und drauf achten, das aus einem > ggf. ein <= wird, um auch die "Grenzwerte" korrekt zu haben.

Antwort bewerten Vielen Dank für Deine Bewertung

Sind zwar schon 8 Antworten da ... aber das wäre eigentlich eine Verweis-Funktion

Antwort bewerten Vielen Dank für Deine Bewertung

wenn Umsätze >= 80.000€ dann zahle 10% Umsatzprovision ende ansonsten wenn Umsätze <80.000€ und Umsätze>50.000 dann zahle 7% Umsatzprovision ende ansonsten wenn Umsätze <= 20.000€ dann zahle 2% Umsatzprovision ende

Antwort bewerten Vielen Dank für Deine Bewertung

=wenn(Umsatz>80.000;Umsatzx10%;wenn(Umsatz>50.000;Umsatzx7%;wenn(Umsatz>20.000;Umsatzx5%;Umsatzx2%))) :)

Antwort bewerten Vielen Dank für Deine Bewertung

Wäre nett, wenn du noch eine "hilfreichste Antwort" auswählen könntest. :) (Dafür kriegst du ja schliesslich auch Punkte ;) )

Antwort bewerten Vielen Dank für Deine Bewertung

Das ist meine Lösung wenn man oben anfängt, falls das jmd wissen will ;)

WENN(Umsatz<=20000;2%;WENN(Umsatz<=50000;5%;WENN(umsatz<=80000;7%;10%)))

Danke für eure Antworten, der Groschen ist wieder gefallen^^ Lieben Dank :)

Antwort bewerten Vielen Dank für Deine Bewertung

Pezi73 29.10.2012, 19:54

dass du da nen Fehler drin hast is dir bewusst?

0

Tipp:

if (a <= b)
{
  if (b <= c)
  {
    doSomething;
  }
  doSomething;
}
Antwort bewerten Vielen Dank für Deine Bewertung

blauegruetze 29.10.2012, 11:08

Ich meine a <= b und a <= c (nicht b <= c). Leider zu spät bemerkt.

0
Oubyi 29.10.2012, 11:12
@blauegruetze

Ich denke hier ist von Excel die Rede, nicht von C++ o.Ä.

0
blauegruetze 29.10.2012, 11:18
@Oubyi

Argh, danke. Ich sollte anfangen mir öfter die Tags durchzulesen.

0

Was möchtest Du wissen?