Variable Daten aus verschiedenen Zellen einer Spalte, in aufeinander vollenden Zellen übernehmen?

... komplette Frage anzeigen

2 Antworten

Nimm mal folgende Formel in C1 und ziehe sie einfach runter:

=WENN(ZEILE(A1)>ANZAHL2(A:A);"";INDEX(A:A;KKLEINSTE(WENN(A$1:A$65000<>"";ZEILE($1:$65000));ZEILE(A1) )))

Da es eine Matrixformel ist bitte mit STRG+SHIFT+ENTER abschließen.

Das sollte deinen gewünschten Erfolg haben.

Klappt es?


Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Oubyi
23.08.2015, 17:43

Du HATTEST Recht.
(Der FS hat bei meiner Antwort reagiert)

1
Kommentar von Glass60
23.08.2015, 18:52

Du denkst richtig. Bei der Formel von Oubyi brauche ich eine Spalte mehr. Also ist Deine Formel genau die richtige. Danke von Glass60

1

Da ich - zumindest auf Anhieb - keine logische Folge in der Auswahl der Zellen sehe, wirst Du wohl jede einzelne mit =A6, =A9 usw. in die Spalte C schreiben müssen.
Oder Du machst in Spalte B neben jeder Zelle, die Du auswählen willst ein X und schreibst dann diese Formel in C1 und kopierst sie runter:

{=WENNFEHLER(INDEX($A$1:$A$1000;KKLEINSTE(WENN($B$1:$B$1000="X";ZEILE($A$1:$A$1000));ZEILE(A1)));"")}

**ACHTUNG!**
Das ist eine Matrixformel.
Das bedeutet: Die geschweiften Klammern {} NICHT mit eingeben,
sondern die Eingabe der Formel NICHT mit ENTER abschließen,
sondern mit: STRG & SHIFT & ENTER (alle drei gleichzeitig).
DAS erzeugt die { } und macht die Formel zu einer Matrixformel.

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von schmiddi1967
23.08.2015, 01:19

Er will wenn ich das richtig verstehe nur alles aus Spalte A ohne Leerzeilen in Spalte C anzeigen lassen.

Ich denke diesmal hast du wieder zu Kompliziert gedacht:))

0

Was möchtest Du wissen?