Ubuntu: The device '/dev/sdb1' doesn't seem to have a valid NTFS.

...komplette Frage anzeigen

2 Antworten

Schau Dir die Platte doch mal GParted an, das sollte bei Ubuntu eigentlich mit dabei sein, ansonsten installiere es über Software Center oder Synaptic.

Also GParted erkennt zwar /dev/sdb1, zeigt aber ein rotes Ausrufezeichen an. Wollte dann die Partition auf Fehler prüfen, das ging jedoch nicht. Ich häng mal die Fehlermeldung an

GParted 0.16.1 --enable-libparted-dmraid

libparted 2.3

Dateisystem (ntfs) auf /dev/sdb1 überprüfen und reparieren  00:00:00    ( FEHLER )

/dev/sdb1 kalibrieren  00:00:00    ( ERFOLG )

Pfad: /dev/sdb1
Anfang: 0
Ende: 1953525167
Größe: 1953525168 (931.51 GiB)
Dateisystem auf /dev/sdb1 auf Fehler überprüfen und (falls möglich) diese beheben  00:00:00    ( FEHLER )

ntfsresize -P -i -f -v /dev/sdb1

ntfsresize v2013.1.13AR.1 (libntfs-3g)
NTFS signature is missing.
ERROR(22): Opening '/dev/sdb1' as NTFS failed: Das Argument ist ungültig
The device '/dev/sdb1' doesn't have a valid NTFS.
Maybe you selected the wrong partition? Or the whole disk instead of a
partition (e.g. /dev/hda, not /dev/hda1)? This error might also occur
if the disk was incorrectly repartitioned (see the ntfsresize FAQ).
========================================
0
@5hplayer

Du scheinst nicht der Erste mit diesem Problem zu sein, wenn Du folgendes bei Google eingibst: "ntfs signature is missing. failed to mount ubuntu" erhältst Du über 50.000 Funde, schau mal, ob da Etwas für Dich dabei ist.

0

Hallo

Hab mir gestern eine neue SSD (/dev/sdc) geholt und Ubuntu aufgespielt.

Nur nebenbei: Warum Ubuntu?

mount -t ntfs /dev/sdb1 /mnt/

Entweder ist das Dateisystem darauf beschädigt, oder es ist gar kein ntfs. Was zeigt denn

sudo fdisk -l
Wenn ich einfach über mount -t ntfs /dev/sdb /mnt/ mounte funktioniert alles

Im Leben nicht!

Man kann keine Festplatte sondern nur Partitionen (mit Dateisystemen) einhängen.

Gibt es einen wegen diese beiden zu entfernen?

Lass erstmal sehen was Fakt ist.

UUID=b3c286b4-52cd-4a4f-a153-7eb3b1622fc4 / ext4 errors=remount-ro 0 1
  1. In der /etc/fstabstehen nur Dateisysteme welche beim booten des Systems eingehängt werden, nicht aber die nachträglich eingehängten.
  2. In der Datei stehen aber noch viel mehr Zeilen als nur die eine, andernfalls wäre da etwas ganz falsch konfiguriert.
  3. Demnach hättest Du nämlich nur eine einzige Partition, also kein /home, auch kein swap oder die von Windows belegte Partition
/dev/sdb /media/HDD ntfs defaults 0 0

Diese Partition hast Du aber selbst hinzugeschrieben und dabei nicht das Format verwendet welches in Deinem System vorgegeben ist. Was zeigt denn ein im Terminal eingegebenes:

ls -l /dev/disk/by-uuid | grep sdb
blkid

an?

Ich würde es ja so schreiben:

UUID_von_SDB[0-9] /windows/D ntfs-3g rw,nosuid,nodev,noexec,relatime,user_id=0,group_id=0,default_permissions,allow_other 0 0

Linuxhase

  1. Wollte mich mal mit Linux auseinander setzen und hatte keine besonderen Wünsche an die Distribution. Ubuntu war das erste, was mir in den Sinn kam ;)

  2. fdisk zeigt folgendes an:

       Gerät  boot.     Anfang        Ende     Blöcke   Id  System
    /dev/sdb1   ?     6579571  1924427647   958924038+  70  DiskSecure Multi-Boot
    /dev/sdb2   ?  1953251627  3771827541   909287957+  43  Unbekannt
    /dev/sdb3   ?   225735265   225735274           5   72  Unbekannt
    /dev/sdb4      2642411520  2642463409       25945    0  Leer
    
  3. Nein, es stehen nur die zwei Einträge in der fstab. Ich bin mir nicht mehr sicher: bei der Installation kam eine Frage wegen SWAP und Partitionen. Da ich weder meine Windows Partition noch meine zweite Partition (auf der Daten und Anwendungen sind) zerschießen wollte, war ich mir unsicher, was ich wählen soll. Und ich bin mir gerade garnicht sicher, ob ich überhaupt irgendeine Partition ausgewählt habe.

  4. grep sdb zeigt Folgendes an:

    lrwxrwxrwx 1 root root 10 Dez  2 17:45 6A4649041DB5D22F -> ../../sdb2
    
  5. blkid zeigt garnichts an. Ich habe beide Befehle nacheinander ausgeführt.

  6. Das Schema für fastab habe ich wiki.ubuntuusers.de/fstab entnommen

0
@5hplayer

@5hplayer

Ubuntu war das erste, was mir in den Sinn kam ;)

Naja, jeder muß sich sein eigenes Bild machen - Welche anderen Distris hast Du schon ausprobiert, resp. im Live-Modus laufen lassen.

fdisk zeigt folgendes an:

  • Das ist aber sicher nicht alles.
    • Bitte vollständig wiedergeben!
  • /dev/sdb1 ist definitiv nicht von Linux angelegt worden
  • /dev/sdb2 und /dev/sdb3 werden als "unbekannt" gekennzeichnet, ergo muß es ein Dateisystem sein das Linux nicht kennt oder gar keines?
    • Ist die Platte aus einem HD-Recorder oder ähnlichem, denn sonst hätte ich keine Erklärung dafür.
  • auch /dev/sdb4 macht mich stutzig.

Nein, es stehen nur die zwei Einträge in der fstab.

Was ergibt denn?:

lsblk
ls -l /dev/disk/by-id

Du mußt aber schon wissen was Du angegeben hast, denn SWAP wird einem dringend nahegelegt.

grep sdb zeigt Folgendes an:

  • Auch da dürfte die Ausgabe unvollständig sein:
    • Wo ist dev/sdb1
    • Wo sind die Partition der ersten Festplatte: /dev/sda geblieben?

blkid zeigt garnichts an.

  • Ich habe noch keine annähernd moderne Distribution gesehen die dieses Kommando nicht kennt.
    • Führt es der normale User aus gibt es (zumindest hier) eine Fehlermeldung, weil dieser Befehl nur von root ausgeführt werden darf.

Das Schema für fastab habe ich wiki.ubuntuusers.de/fstab entnommen

Wenn Deine Angaben stimmen, dann müsste es bei Dir so passen:

6A4649041DB5D22F /mnt ntfs-3g rw,nosuid,nodev,noexec,relatime,user_id=0,group_id=0,default_permissions,allow_other 0 0

Was aber wohl dennoch nicht klappen wird weil sdb ja nicht mit einem, für Linux lesbaren, Dateisystem versehen ist.


Wenn Du Ubuntu installiert hast, dann ganz sicher nicht auf der angegebenen Festplatte.

Linuxhase

0

Was möchtest Du wissen?