Teilergebnis + Zählenwenn Filtern?

1 Antwort

Schreib dir eine Funktion, die ermittelt, ob eine Zelle ausgeblendet ist und nutze diesen Wert in ZÄHLENWENNS oder SUMMENPRODUKT.

Hier wird es erklärt: http://www.computerwissen.de/office/excel/artikel/sichtbarkeit-einer-zelle-ermitteln.html

TEILERGEBNIS benötigst du dann nicht mehr.

PS: Von TEILERGEBNIS würde ich sowieso abraten.

Ich weiß nicht, ob du dir die einzelnen Nummern merken kannst, aber ich muss immer wieder nachschlagen, welche Zahl für welche Funktion steht.

Da hätte man besser Enumerationswerte anbieten können oder wenigstens wie in der Funktion ZELLE Textkonstanten zulassen können.

Falls das eine Schulaufgabe sein soll, sollt ihr bestimmt nur herausfinden, wie schwach TEILERGEBNIS ist.

0

Ich muss dazu sagen, ich bin kein Excel Pro. Mit Teilergebnis bin ich sehr zufrieden und würde da auch gerne bei bleiben.

0
@Sibbe18

Die Funktion hat ihre Grenzen, an die du gerade gestoßen bist. Man kann nur eine übersichtliche Anzahl an Funktionen auf einen gefilterten Bereich mittels TEILERGEBNIS anwenden.

0
@Sibbe18

Gerade Nicht-Pros rate ich davon ab. (Ich frage dich morgen mal, wofür "TEILERGEBNIS(107;..." steht ;P

0
@Sibbe18

Wenn zum Beispiel Spalte C die Spalte ist, in der du die Werte filterst und du in Spalte D ohne Beschränkung der Allgemeinheit die Formel =SICHTBAR(C2) heruntergezogen hast (siehe Link in der Ausgangsantwort), dann lautet die Formel, die alle eingeblendeten, negativen Zahlen zählt:

=ZÄHLENWENNS(C2:C5;"<0";D2:D5;WAHR)

Ich habe testhalber nur auf 4 Zeilen (2:5) gefiltert.

0

Was möchtest Du wissen?