Teilergebnis + Zählenwenn?

...komplette Frage anzeigen

5 Antworten

Wenn du eine schnelle Lösung benötigst, könntest du eine Spalte in deiner Tabelle anlegen, in denen Einsen stehen, wenn der Betrag ungleich 0 ist.

Dann kannst du mit der Teilergebnisformel für die Summe (9) über diese Spalte summieren und somit die eingeblendeten Zeilen zählen, deren Betrag ungleich 0 ist.

=SUMMEWENN(A:A;">0")

=SUMMEWENN(A:A;"<0")

Gilt für  Excel und LibreOffice Calc

ich brauch das in kombi mit teilergebnis

0
@Sibbe18

Abgesehen davon, dass das ZÄHLENwenn heissen müsste: was soll der Blödsinn mit dieser Kombi? Von hinten durch die Brust ins Auge?

Wenns eine Hausaufgabe ist, dann schau in der Hilfe für Teilergebnis nach, oder weigerst Du Dich, was zu lernen?

1

=SUMMENPRODUKT(TEILERGEBNIS(3;INDIREKT("A"&ZEILE(2:20)))*(A2:A20>0))

http://www.herber.de/forum/archiv/580to584/583782_Summewenn_und_Teilergebnis_kombiniert.html Formel etwas verkürzt, da Du nur die Anzahl und nicht die Summe willst.

Für die Werte kleiner Null halt <

kannst du erklären warum 2:20 ????? 

0
@Sibbe18

weil hier keiner aus Lust und Tollerei eine Tabelle mit 10000 Einträgen anlegt, nur um Dir die richtige Adresse zu liefern!

Soviel wirst Du doch noch selbst hinkriegen!??

0
@Iamiam

Wenn ich ausprobiere, ob eine Formel funktioniert, fummel ich eine kleine Beispieltabelle zusammen. Du hast (als eine seltene Ausnahme bei den Fragen) tatsächlich genannt, wo Deine Werte stehen - die meisten machen das nicht, dann muss ich halt irgendwas annehmen. Im konkreten Fall wäre A bei Dir eben M und der Bereich 2:20 müsste 8:10000 sein.

0

Wäre die schnellste Lösung nicht "=ZÄHLENWENN(M8:M10000;"<>0")Funktioniert bei mir super.

nur leider aktuallisiert es sich nicht wenn ich nach beispielsweise einem Lieferanten filtere

0

um was für eine DB handelt es sich denn?

Was möchtest Du wissen?