Tabellenkalkulations-Hilfe (WENN-,SONST-,UND-Funktionen)?

... komplette Frage anzeigen

3 Antworten

Man kann das mit (geschachtelten) WENN-Funktionen machen - das ist grausig viel Aufwand und völlig unübersichtlich. Macht man dabei irgendeinen Fehler, wird es äußerst mühselig, ihn zu korrigieren und zu beheben.

Sinnvoller erscheint es mir, das mit einem SVERWEIS zu machen. Dazu legst du ein weiteres Tabellenblatt an, in dem du in den Zeilen das Alter angibst und in den Spalten den BMI. Dann gibst du in den Feldern der dadurch festgelegten Matrix an, ob der jeweilige BMI für das jeweilige Alter ok ist oder unter- bzw. übergewichtig.

SVERWEIS sucht dann in der ersten Spalte nach dem Alter. Wenn der passende Wert gefunden wird, gibt die Funktion den Wert aus der n-ten Spalte aus. Für n definierst du in irgendeiner Zelle =[Alter-x], je nachdem, wie du deine Tabelle angelegt hast.

In meinem Beispiel habe ich das in LibreOffice ausprobiert. Bei Excel oder anderen Programmen mag die Syntax etwas anders aussehen, müsste aber ähnlich sein. Die Funktion SVERWEIS sucht sich den in Zelle B13 eingegebenen Wert (der natürlich auch aus deiner ursprünglichen Tabelle abgefragt werden kann) und sucht dann innerhalb der Matrix A3:Q9 den Wert der n-ten Spalte. n habe ich in der Zelle B15 definiert, das ist einfach der BMI (aus Zelle B12) minus 13 (weil Alter 15 in der zweiten Spalte steht usw).

Das Bild zeigt nur eine kleine Tabelle, die ich zur Veranschaulichung angelegt habe. Du kannst das natürlich beliebig erweitern. Die eigentliche Funktion, der SVERWEIS, bleibt davon unberührt - nur die dort definierte Matrix musst du ggf. anpassen.

Für Irrtümer übernehme ich weder Gewehr noch Pistole. Ich wollte hier einen Weg aufzeigen, solche Aufgaben einfacher zu lösen, auch wenn man sich dazu zunächst mit einer ziemlich kompliziert aussehenden Funktion plagen muss. Es lohnt den Aufwand - wenn man bei der WENN-Funktion an die zehnte Schachtelungsebene gelangt, ist nämlich Feierabend (falls bis dahin nicht bereits die Jungs mit den weißen Kitteln angerückt sind).

Kommentar von LG239
13.10.2016, 21:52

Hey danke :), das ist mir bewusst das es mühselig und aufwändig ist aber leider muss ich das machen :/, eben genau mit den verschachtelten funktionen. Wäre echt der wahnsinn wenn du das für mich machen könntest! Aber wenn es dir zu viel aufwand ist, ist es egal. LG :)

0

Ist die Anforderung tatsächlich, wortwörtlich, dass nur eine Wenn-Formel verwendet werden soll? Da man sowohl beim Alter, als auch beim BMI nicht nur einen festen Wert, sondern einen Wertebereich prüfen muss, macht man sich mit einer verschachtelten Wenn-Formel ja tot.

Es gibt noch andere Funktionen zur Variante von Oubyi, aber das Prinzip wäre das gleiche: Erstmal die vom Alter abhängige Ober- und Untergrenze ermitteln und dann den Abgleich mit dem tatsächlichen BMI. Da steckt schon eine Wenn-Formel drin, die sollte man aber wirklich nicht für alles nutzen.

Nur mit einer Wenn-Formel brauchst Du alleine für die erste Altersgruppe:

=WENN(UND(B4<25;B3>=19;B3<=24);"OK";WENN(UND(B4<25;B3>24);"Übergewicht";WENN(UND(B4<25;B3<19);"Untergewicht";"")))

Kommentar von LG239
13.10.2016, 21:48

Danke. An sich hast du verstanden was ich will aber es soll entschieden werden ob unter oder übergewicht bzw ein wünschenswerter bmi anhand des alters zutrifft.

0

Am besten machst Du Dir dazu ein Liste, wie in meinem Screenshot im Bereich A10:C16.
Dann ist die Formel für B5:

=WENN(B3<VERWEIS(B4;$A$11:$A$16;$B$11:$B$16);"Untergewicht";WENN(B3>VERWEIS(B4;$A$11:$A$16;$C$11:$C$16);"Übergewicht";"wünschenswert"))

Teste das mal genau.
Klappt es?

Kommentar von LG239
13.10.2016, 19:50

Hi, Danke für die Arbeit! Leider funktioniert es bei mir nicht. Fehler bei prüfung; #NV, aber ist es auch möglich das ganze nur mit wenn und dann sonst funktionen zu machen? Und ohne die $ zeichen?

0

Was möchtest Du wissen?