Systemimage von Raspbian über dd auf SD-Karte funktioniert nicht?

2 Antworten

du hast zwar viel Text geschrieben, nicht aber das, was du gemacht hast. Einfach nur "mit dd" kopiert reicht da nicht aus. Welche Parameter hast du benutzt?  Hast du die beiden Images verglichen? Das Ziel-Image mal mit Ubuntu gemountet?  ( mount -o loop /dev/<SD-Karte> /mnt)

sudo dd bs=4M if=~/2015-11-21-raspbian-jessie.img of=/dev/sdc

Wie gesagt, mit einem anderen Computer, auf dem auch Ubuntu 15.04 läuft funktioniert es, mit der selben Datei. Komischerweise kann ich mit meinem Laptop auch danach nicht sehen, was auf der SD-Karte drauf ist. Mit dem anderen PC geht das aber.

0
@PHoel

daran ist nichts auszusetzen. Bleibt nur noch die Image-Datei selbst, die einen Fehler hat. So etwas kann passieren, wenn Windows im Spiel war und bei der Übertragung 0aH ( Linux ) gehen 0a0dH (Windows) ausgetauscht wurde. Das ist die Kennung "Zeilenende" in ascii-Dateien.

0
@guenterhalt

Windows war nicht im Spiel, das Image funktioniert auch bei einem anderen Computer, es ist wirklich die selbe Datei, also rüberkopiert.

0
@PHoel

leider hat gutefrage.net einen Kommentar wieder gelöscht. Warum? Ich weiß es nicht.

Hier nur noch ein Ausschnitt:

" .... Geräte, die nur SD-1.0-Industriestandard unterstützen (ältere
Kartenleser und oft auch neuere interne von Notebooks), lesen
2-GB-Karten manchmal, verursachen aber Fehler im Speicherbereich über 1 GB. .."

Quelle: https://de.wikipedia.org/wiki/SD-Karte

0
@guenterhalt

Hm, keine Ahnung was bei gf.net schief geht... Auf jeden Fall habe ich es ja auch mit einem externen USB 3.0 Kartenleser probiert und es hat auch nicht funktioniert.

0
@PHoel

Aufgeben gibt es bei mir normalerweise nicht, hier muss ich es aber machen.

1

Ich hatte das gleiche Problem, nur das ich ein Mac habe, bei mir musst man das rdisk durch disk ersetzten , oder anders rum.

MFG

Wo meinst du ersetzen? Eine genauere Erklärung wäre hilfreich ;)

0

Bei den Befehl den man für Mac/Linux benötigt steht an einer Stelle rdisk bzw disk , versuche mal das was bei dir steht durch das andere zu ersetzten, bei kir hat es dann geklappt.

0
@ICloud38

Ich habe diesen Befehl genommen, da ist nichts mit fdisk oder rdisk.:

sudo dd bs=4M if=~/2015-11-21-raspbian-jessie.img of=/dev/sdc
0

okay, der sieht etwas anders aus , ersetzte mal das große M hinter der 4 durch ein kleines m und sag bitte, ob es geklappt hat. MFG

0

Was möchtest Du wissen?