SVerweiß +Links-Funktion?

... komplette Frage anzeigen

1 Antwort

Spalte B: Beispiel 01
Spalte C: Beispiel 01

Das oben verstehe ich nicht wirklich.
Was heißt Du brauchst die letzten zwei Zeichen nicht?
Soll nur nach Beispiel gesucht werden, egal was dahinter steht.
Und meinst Du zwei oder drei Zeichen ( 01 sind drei Zeichen)
Und warum überhaupt einen SVERWEIS  um den gleichen Wert wie in C wiederzugeben? Da ist Zählenwenn sinnvoller.
Aber ich mache mal eine Versuch.

Ich verstehe es mal so, dass Du in C2 z.B. "Beispiel" stehen hast, und in Spalte B irgendwo z.B.: "Beispiel01" steht und Du DAS in der Formelzelle (A2) sehen willst. Dann:

{=INDEX(B1:B4147;MAX((C2=WENNFEHLER(LINKS(B1:B4147;LÄNGE(B1:B4147)-2);9^9))*ZEILE(B1:B4147)))}

**ACHTUNG!** Das ist eine Matrixformel.
Das bedeutet: Die geschweiften Klammern {} NICHT mit eingeben, sondern die Eingabe der Formel NICHT mit ENTER abschließen, sondern mit:
STRG & SHIFT & ENTER (alle drei gleichzeitig).
DAS erzeugt die { } und macht die Formel zu einer Matrixformel.

Falls das in Spalte B mehrmals vorkommt, wird aber nur der letzte Wert angezeigt.

Antwort bewerten Vielen Dank für Deine Bewertung

Was möchtest Du wissen?