SVERWEIS mit mehreren Suchfunktionen?

Tabellenblatt 1 - (Computer, PC, Microsoft) Tabellenblatt 2 - (Computer, PC, Microsoft)

4 Antworten

Mehrere Kriterien gleichzeitig kannst du mit ZÄHLENWENNS abfragen. (Beachte das S am Ende des Namens)

Du kannst z. B. danach fragen, wo ZÄHLENWENNS(X$1:X23;...)-ZÄHLENWENNS(X$1:X22;...)>0 ist - vermutlich als "Matrixfunktion".

SVERWEISS und VERGLEICHS scheint es nicht zu geben.

-----

Oder du nimmst eine zusätzliche Spalte und setzt dort die Kriterien hintereinander (ggf. durch ein Trennzeichen getrennt).

Eigentlich sollte das mit SUMMEWENNS lösbar sein:

=SUMMEWENNS(Plan_2018!D1:D1000;Plan_2018!A1:A1000;C4;Plan_2018!C1:C1000;L9)

Bereiche ggf. anpassen.
Klappt es?

so würde ich es auch angehen. vom Bild her glaube ich, es müsste L8 genommen werden, nicht L9 :-)

Vielleicht noch also Hinweis für den Fragesteller: A319 sollte überall gleich geschrieben werden. Bei dir ist es in der einen Liste ohne Leerstellen, in der anderen mit.

1

SUMMENPRODUKT  müsste gehen

=SUMMENPRODUKT((A:A="HAM")*(C:C="Ergebnis")*D:D)

(ungetestet)

Es kann sein, dass du die Bezüge mit Zeilen angeben musst.

Aber Zelle C4 soll ja zunächst leer bleiben. Erst wenn man dort z.B. HAM eingibt, sollte mit dem SVERWEIS zunächst in dem zweiten Tabellenblatt nach HAM und dann noch nach A319 gesucht und deren Gesamtergebnis 12.302 angezeigt werden.

Wenn ich z.B. im Tabellenblatt in der Zelle C4 INN eingebe, sollte automatisch in der Zelle L10 der Wert 41 angezeigt werden.

0
@onyx1985

Das Eingabefeld sollte ein anderes sein als das, in dem das Suchergebnis erscheinen soll.

Das wollen viele User gerne, die Fragen zu Excel haben. Ich frage mich, wie ihr darauf kommt. Das ist doch in kaum einem Programm so, dass Eingabefelder zugleich Ausgabefelder sind.

0
@onyx1985

Achso, wenn ich das nun richtig verstehe, musst du halt Spalte A auf C4 abfragen und Spalte C auf eine der Zellen L8 bis R8.

0
@Suboptimierer

ja richtig, aber der Zusammenhang muss halt bestehen sein, sprich HAM = A319 = 12.302 bzw. HAM = A320 = 7.983

0

Excel wenn zelle von bis im tabellenblatt 2 farbe dann zelle von bis Tabellenblatt 1 gleiche Farbe

habe einen Jahres urlaubsplan unter Arbeitskollegen erstellt. Wo deren Urlaub von allem auf einem Kalender eingeplant wird ( Tabellenblatt 2 ) und auf ( Tabellenblatt 1 ) soll dann dem entsprechend in dem Monat für die jeweilige Person die Farbe mit übernehmen.

Quasi:

Excel wenn zelle von bis im tabellenblatt 2 farbe dann zelle von bis Tabellenblatt 1 gleiche Farbe

...zur Frage

Excel VBA. Wie kann ich eine Zelle in ein anderes Tabellenblatt in eine bestimmte Spalte einfügen?

Wie kann ich zum Beispiel aus Tabellenblatt Zelle A11 Werte in Tabellenblatt 2 kopieren und dabei Spaltte "B" hineinkopieren? Außerdem soll Excel immer in die nächste frei Zeile die Werte hineinkopieren.

...zur Frage

In Excel Tabellenblatt mit anderen Tabellblättern verknüpfen

Hallo,

ich habe bei Excel folgendes Problem:

Ich habe eine Statistik in einem Tabellenblatt erstellt, in der Statistik habe mehrere farbliche Spalten, in denen ich bisher geänderte Werte noch per Hand eintrage z.B. steht in der grau hinterlegten Zelle 33, in der blau hinterlegten Zelle 24 und in der gelb hinterlegten Zelle 48.

Die Werte stammen aus verschiedenen Tabellenblättern z.b Tabellenblatt 1, Tabellenblatt 2 sowie Tabellenblatt 3 und werden bisher bei einer Veränderung in der Statistik per Hand verändert. Ich suche für Excel jetzt eine Formel, bei dem ich dieser Vorgang automatisiert wird.

Ich möchte also, dass wenn ich im Tabellenblatt 1 eine Zelle grau markiere bzw. hinterlege, dass sich in dem Tabellenblatt, in der sich die Statistik befindet, automatisch die Zahl in der grau hinterlegten Zelle von 33 auf 34 addiert. Natürlich soll das auch umgekehrt klappen, wenn ich eine Zelle wieder entmarkiere.

Kann mir jemand weiterhelfen?

Danke...

...zur Frage

Was möchtest Du wissen?