SVerweis funktioniert nur halb

2 Antworten

Vom Fragesteller als hilfreich ausgezeichnet

Erst mal kontrollieren, ob Du die $-Zeichen richtig gesetzt hast. Die brauchts, wenn Du die Formel nach unten kopierst. Und das Keywort "falsch" wird auch rein müssen in die Formel.


Jup hab ich alles.

0

Ja kann daran liegen.

Habs gerade mal probiert, indem ich die Pivottabelle in eine normale umgewandelt habe. Liegt nicht daran...

0

Excel: sverweis funktioniert in jeder 3.zeile nicht?!

Hello liebe Excel-Experten,

ich hab ein Problem, dass ich nicht ganz verstehe. Ich habe 2 Tabellenblätter, wobei im 1. Blatt die Daten 1.1.2010 00:00 bis 31.12.2010 23:00 in Spalte A untereinander stehen. In Spalte B gibt es einen Sverweis, der Spalte A mit einer Matrix im 2.Tabellenblatt (Spalten A-D) verlgleichen soll und INhalt der Spalte D ausgibt. Im 2. Tabellenblatt gibt es in Spalte A eine Wenn-Formel, die sich auf B bezieht.

Spalte A aus Blatt 1 = Spalte A aus Blatt 2 (eigentlich). Hab das mit verschiedenen Formatierungen überprüft. Es gibt meines Wissens nach keinen Unterschied. Trotzdem findet der sverweis jeden 3. Wert NICHT! (und das bei 8760 Werte) obwohl die Werte garantiert vorhanden sind. Formeln und Formate sind die selben!

Ich kann mir nicht erklären, warum das so ist und bitte euch um euer Wissen!

Danke, LG Carina

...zur Frage

Excel soll Automatisch Text ausfüllen wenn eine Zahl angegeben wird?

Hallo

Ich bekomme eine Liste mit Zahlen und muss diese dann in Excel eintragen, bzw. Raussuchen welches Wort zu welcher Zahl passt und dann das noch eingeben. Excel soll dann anhand der von mir angegeben Zahl in einerm anderen einen Passenden Text hinsetzten. Wenn aber nichts da steht soll da nicht WERT oder NAME oder so stehen sondern es soll leer bleiben.

Beispiel Ich bekomme die Liste Name | Datum | Objekt

Das Objekt ist nur eine Zahl

Hans | 1.6.16 | 5

Excel soll mir dann neben der Zahl das Objekt in Worte fassen

Hans | 1.6.16 | 5 | Garten

Wenn dann aber bei der Objekt Zahl noch kein Wert drin steht soll da auch nichts stehen. Auch kein Fehler.

Zudem möchte ich die Formel eingeben können und einmal nach unten ziehen und nicht jedesmal alles eingeben müssen.

Ich habe alle Werte in der Selben Arbeitsmappe in Tabelle 2 eingegeben. In Tabelle 1 Arbeite ich.

Tabelle 2 sieht in etwa so aus

1 | Wohnung 2 | Haus 3 | Platz 4 | Abstellraum 5 | Garten

Habe dann versucht das ganze mit sverweis zu lösen.

=SVERWEIS(B1;Tabelle2!A1:B16;2)

Sprich Wenn in B1 eine Zahl steht; Aus Tabelle 2 A1-B16; in der zweiten spalte dann soll er das Wort dahinter nehmen.

Klappt soweit ziemlich gut, nur Probelem sind trotzdem da.

  1. Wenn noch Kein Wert (Zahl) in Tabelle 1 steht dann steht da #NV Wie bekomme ich das Weg?

  2. Ich kann die Formel nicht runter ziehen sonst werden alle Werte geändert

=SVERWEIS(B1;Tabelle2!A1:B16;2) =SVERWEIS(B2;Tabelle2!A2:B16;3) =SVERWEIS(B3;Tabelle2!A3:B16;4)

jedoch sollte es beim runterziehen der Formel so aussehen:

=SVERWEIS(B1;Tabelle2!A1:B16;2) =SVERWEIS(B2;Tabelle2!A1:B16;2) =SVERWEIS(B3;Tabelle2!A1:B16;2)

Weil die Matrix (A1:B16) bleibt ja die selbe.

Bin dankbar über jeden Rat. Es muss nicht mit sverweis gelöst sein. Jedoch suchen und ersetzen ist auch keine Option, da es zum einen mehr aufwand ist und zum anderen benötige ich ja die Zahl und das dazugehörige Wort.. Geht aber auch nicht immer.

Danke euch Gruss Grischabock

...zur Frage

Was möchtest Du wissen?