Problem mit Open Office Calc: würde gerne durch eine Funktion abweichende Rechnungsbeträge bzw. bezahlten Skonto rechnen lassen - Vorschlag mit #NAME? anbei!!!

...komplette Frage anzeigen

3 Antworten

Hat _0 eine bestimmte Bedeutung bei Open Office? In Excel wäre das ein Text und muss in "" stehen.

Das Summe kannst Du aus meiner Sicht weglassen, es reicht die verschachelte Wenn abfrage.

Die Prüfung, ob B9 oder B10 größer ist, kann auch entfallen, wenn in Calc die Funktion für Betrag geht, also ABS

=ABS(B9-B10)+B7

zusammen wäre es dann

=WENN(B10=0;0;ABS(B9-B10)+B7)

Die Sache mit den Unterstrichen kann ich als Excelnutzer nicht beurteilen.

Antwort bewerten Vielen Dank für Deine Bewertung
PCeo93 07.06.2016, 13:07

Richtig gut!!! Funktioniert einwandfrei, vielen herzlichen Dank Dir für die schnelle und simple Lösung :))

0
Iamiam 07.06.2016, 18:29
@PCeo93

@Ninombre: Der Unterstrich hat in OO KEINE besondere Bedeutung, höchstens, dass er -wie in xl auch- die 0 in den TEXT _0 verwandelt und die 0 damit nicht mehr rechenbar ist.

@ PCeo93: Du kannst als benutzerdefiniertes Zellformat die 0 als _0 anzeigen lassen, dann hat das auf die Berechnung keinen Einfluss. ich lass mir die Null meist als unauffälliges magentafarbenes ° anzeigen, dann sieht man einerseits, dass in der Zelle was steht, andererseits unterscheidet sich das markant von anderen Zahlen. Und noch ein Clou dabei: ein 0,00001 wird in der Zelle meist als 0 dargestellt und ist nicht unterscheidbar von einer 0,00000, als magentafarbiger Kringel aber kannst Du die exakte 0 gut von der Zahl 0,00001 unterscheiden!

Zellformat in OO (wie in xl):

0;[ROT]-0;[MAGENTA]°;[GRAU]@

Aus xl wurden etliche Formate NICHT nach LO übernommen, waren dort aber so definierbar!

0

Lass mal das "dannUnterstrich" und "sonstUnterstrich" weg.

Antwort bewerten Vielen Dank für Deine Bewertung

Wie lautet denn die Formel in der Zelle buchstäblich?

Wozu hast du überhaupt das dannUnterstrich und das sonstUnterstrich eingefügt?

Antwort bewerten Vielen Dank für Deine Bewertung
PCeo93 07.06.2016, 13:06

Die Unterstriche hatte es in der Anzeige leider nicht übernommen, deshalb habe ich die alle manuell ersetzt, damit sie für Euch lesbar werden. Die Formel siehst du oben :)

0
PWolff 07.06.2016, 13:13
@PCeo93

Nach Lesen mit den anderen Kommentaren scheint mir, du hast da anscheinend was missverstanden: in

WENN(Bedingung; dann_Wert; sonst_Wert)

sind dann_Wert und sonst_Wert als je ein kompletter Ausdruck zu betrachten.

(P. S.: hab grad nochmal in die OpenOffice-Hilfe hineingeschaut: dort steht

WENN(Prüfung; DannWert; SonstWert)

)

0

Was möchtest Du wissen?