Summenbereich verändern

...komplette Frage anzeigen

1 Antwort

Die Frage ist zwar nun schon etwas älter, aber ich habe hier eine Lösung für das Problem:


1) Du willst pro Zeile, die du im Summenblatt weitergehst im Datenblatt 96 Zeilen weitergehen. Die Summenzeile bekommst du über die Funktion ZEILE. Also müssen die Funktionen schon mal wie folgt heißen:

  • Für den untersten Wert des Bereichs:

    =ZEILE(Tabelle1!A1)*96-95

  • Für den obersten Wert des Bereichs:

    =ZEILE(Tabelle1!A1)*96


2) Nun haben wir also für jede Zeile Summenzeile die jeweilgen Bereiche. Jetzt müssen wir noch dafür sorgen, dass bei jeder neuen Zeile auf dem Summenblatt das Ergebnis um den jeweiligen Bereich verschoben wird. Dafür gibt es die Funktion BEREICH.VERSCHIEBEN.

  • Für den untersten Wert des Bereichs:

    BEREICH.VERSCHIEBEN(Tabelle1!A1;(ZEILE(Tabelle1!A1)*96-95)-ZEILE(A1);0)

  • Für den obersten Wert des Bereichs:

    BEREICH.VERSCHIEBEN(Tabelle1!A1;(ZEILE(Tabelle1!A1)*96)-ZEILE(A1);0)


3) Zu guter Letzt müssen die beiden Formeln nur noch zu einer Summe zusammengebaut und anschließend durch 4 dividiert werden:

=SUMME(BEREICH.VERSCHIEBEN(Tabelle1!A1;(ZEILE(Tabelle1!A1)*96-95)-ZEILE(A1);0):BEREICH.VERSCHIEBEN(Tabelle1!A1;(ZEILE(Tabelle1!A1)*96)-ZEILE(A1);0))/4

Was möchtest Du wissen?