Suchmaske in Excel erstellen

...komplette Frage anzeigen

2 Antworten

Teste mal:
Produkt/ Farbe/ Monat in Spalte A/B/C, Kosten in Spalte D.
Eingabe von Produkt/ Farbe/ Monat in G1/H1/I1.
Formel:

{=INDEX($D$1:$D$10000;VERGLEICH(G1&H1&I1;$A$1:$A$10000&$B$1:$B$10000&$C$1:$C$10000;0))}

ACHTUNG!
Das ist eine Matrixformel.
Das bedeutet: Die geschweiften Klammern {} NICHT mit eingeben, sondern die Eingabe der Formel NICHT mit ENTER abschließen, sondern mit:
STRG & SHIFT & ENTER (alle drei gleichzeitig).
DAS erzeugt die { } und macht die Formel zu einer Matrixformel.

Klappt es?

Du schreibst in Deinem Kompliment (DANKE!):

Vielen Dank für die Formel! Sie klappt auch soweit ganz gut, allerdings habe ich sehr viele Spalten in meiner Tabelle, die die formel durchlaufen soll und ich möchte ungern jede einzelne Spalte manuell eintragen. Die Formel wird dann ja auch sehr riesig werden....Außerdem möchte ich dass mir die kumulierten kosten von bsp drei monaten ausgegeben werden...weißt du wie ich hier die formel ergänze?

Um Dir da weiterhelfen zu können, solltest Du eine Beispieldatei bei einem Upload-Service (z.B. http://www.file-upload.net) hochladen und hier den Link einstellen.
Am besten beschreibst Du darin nochmal, welche Ergebnis Du erwartest.
augsburgchris, der Dir jetzt auch geantwortet hat (und Dich etwas anders versteht als ich), kann das sicherlich auch gut weiterhelfen.
Also - wenn Du eine Datei hochlädst - sag uns BEIDEN kurz in einem Kommentar Bescheid, dann schauen wir mal.

0

Spalte A: Produkte

Spalte B: Farben

Spalte C: Monate

Spalte D: Bruttokosten

F1: Produkt

F2: Farbe

F3: Monat

F4: =SUMMENPRODUKT((A2:A1000=F1)*(B2:B1000=F2)*(C2:C1000=F3)*(D2:D1000))

Was möchtest Du wissen?