Stundenberechnung in Excel (teilweise länger als 24 Uhr)

...komplette Frage anzeigen

2 Antworten

Es gibt noch drei Möglichkeiten:

a) =C4-C3+(C4<C3)

b) =REST(C4-C3;1)

c) Man könnte auch beide Zeiten in Dezimalzahlen umwandeln und per Wenn-Funktion die Differenz bilden. Vorteil dieser Methode ist, daß man das Ergebnis weiterverrechnen kann, z.B. mit einem Stundenlohn multiplizieren.

Also bei a) kommt was komisches raus... b) funktioniert super... Danke! ABER... Du hast schon einen Schritt weiter gedacht als ich... ich müsste dann wohl zu "c" greifen, weil ich den Stundenlohn auch ausrechnen lassen möchte... Magst Du so freundlich sein, mir zu erklären, wie ich das mache??

0
@Titschy

Also ICH arbeite immer mit der Formel in b).
Um nicht die Zeit zu erhalten, also
z.B. 4:30 h,
sondern den Stundenwert als Zahl, also
4,5
brauchst Du das Ergebnis nur mit 24 zu multiplizieren (da Excel 1 h als 1/24 Tag berechnet). Also wäre die Formel für die Anzahl der Stunden:
=REST(C4-C3;1)*24
Das ergibt dann 4,5 und die kannst Du mit dem Stundenlohn multiplizieren, oder was Du sonst machen willst.

0
@Titschy

Hallo, Tischy,

Danke für Deine Rückmeldung. Bei Formel a) kommt das richtige raus, wenn die Ergebniszelle folgendes Format hat: [h]:mm

Betr. Rechnung in Dezimalen: In C5 habe in die Start-Uhrzeit als Dezimalwert stehen, z.B. 22,5 für 22 Uhr 30. In D5 habe ich die End-Uhrzeit als Dezimalwert stehen, z.B. 2,75 für 2 Uhr 45.

Dann berechne ich so die Arbeitszeit:

=WENN(D5>C5;D5-C5;24-C5+D5)

Heraus kommt 4,25, was man mit 20 Euro multiplizieren kann, dann erhält man 85 Euro. Grüße von fragator

0

ich würd eher das vorschlagen:

=WENN((C4-C3)<0;24-C3+C4;C4-C3)

Du hast meine Formel nur umgestellt, das läuft auf Dasselbe hinaus.

0
@Kriwanek

hast meine Formel probiert - die funktioniert egal von wann du bis wann arbeitest.

0
@Pezi73

Hab ich. Meine funktioniert genau so, wenn man den Tippfehler korrigiert hat ;-)

=WENN(C4-C3>=0;C4-C3;C4-C3+24)

Du hast da übrigens noch ein überflüssiges Klammerpaar in deiner Formel drin.

0

Was möchtest Du wissen?