Spiele in Excel

...komplette Frage anzeigen

6 Antworten

Ich würde zum Programmieren solch recht einfacher Spiele Flash nehmen. Das hätte unter anderem den Vorteil, dass es fast auf jeder Kiste incl. vielen Handys läuft.

Außerdem kann man es direkt im Internet zum spielen veröffentlichen.

Ja das geht mit formeln oder vba oder beidem. auf excelformeln (mit ww. und .de)gibt es zum Beispiel kniffel oder minesweeper ohne vba. Auf www.excelgames.org gibt es viele spiele mit vba. Wenn du z. B. in A1 den Namen von Spieler 1 einträgst und in B1 sein Symbol (z. B. X oder O) und in A2 den Namen von Spieler 2 und in B2 sein Symbol kannst du wenn du noch z.B. die Zellen D6 bis F8 zum Spielfeld machst, und in eine danebenliegende Zelle die Formel =WENN(ODER($D$6&$D$7&$D$8=WIEDERHOLEN(B2;3);$D$6&$E$6&$F$6=WIEDERHOLEN(B2;3);$F$6&$F$7&$F$8=WIEDERHOLEN(B2;3);$D$8&$E$8&$F$8=WIEDERHOLEN(B2;3);$E$6&$E$7&$E$8=WIEDERHOLEN(B2;3);$D$7&$E$7&$F$7=WIEDERHOLEN(B2;3);$D$6&$E$7&$F$8=WIEDERHOLEN(B2;3);$F$6&$E$7&$D$8=WIEDERHOLEN(B2;3));A2&" hat gewonnen!";WENN(ODER($D$6&$D$7&$D$8=WIEDERHOLEN(B3;3);$D$6&$E$6&$F$6=WIEDERHOLEN(B3;3);$F$6&$F$7&$F$8=WIEDERHOLEN(B3;3);$D$8&$E$8&$F$8=WIEDERHOLEN(B3;3);$E$6&$E$7&$E$8=WIEDERHOLEN(B3;3);$D$7&$E$7&$F$7=WIEDERHOLEN(B3;3);$D$6&$E$7&$F$8=WIEDERHOLEN(B3;3);$F$6&$E$7&$D$8=WIEDERHOLEN(B3;3));A3&" hat gewonnen!";"")) einträgst kannst du mit den verwendeten Symbolen eine Runde TicTacToe spielen.

Meines Wissens nach sind es bloß eastereggs, die die Programmierer eingebaut haben und die sind nicht überall vorhanden.

Was möchtest Du wissen?