Spalten-Summe bis zur vorletzten belegten Zeile

3 Antworten

Vom Fragesteller als hilfreich ausgezeichnet

Mit INDIREKT:
=SUMME(INDIREKT("J13:"&"J"&(ANZAHL2(J:J)-1)))
Aber VORSICHT, das mit ANZAHL klappt nur, wenn alle Zellen gefüllt sind, also keine Leerzellen zwischendrin auftauchen. Sonst geht das "in die Hose".

Hallo Oubyi,
Leerzeilen sind definitiv keine drin in der Spalte von J13:J(letzte Zelle)
aber mit der Formel stimmt was nicht, sie liefert immer =0.
Ich teste mal und melde mich wieder...

0
@PinoGrigio

Oubyi,
deine Formel ist richtig!
Der Fehler lag bei mir!
Ich hatte deine Formel auf J9 eingetragen und bekam so einen Zirkelbezug, weil ANZAHL2(J:J) die ganze Spalte J betrachtet und bei einem Zirkelbezug immer =0 lieferte.
Wenn ich deine Formel nicht in Spalte J setze, funktioniert es bestens!
Danke

0

Probier es doch mit einer Hilfsspalte. Alle Zahlen bekommen einen Indikator, nur diese vorletzte Zahl nicht. Über den kann man dann mit SUMMEWENN summieren. Alternative könnte sein, dass man dieser Funktion für die vorletzte Zahl einen Namen zu weist, auf den man sich bei der Summenformel beziehen kann.

...und wie würde dann diese Summenformel mit diesem Namen lauten?
=Summe(J13:J&Name) das geht wahrscheinlich genausowenig wie meine Formel.

0
@PinoGrigio

Doch, das würde auch gehe:
=SUMME(J13:vorletzteZelle)
funktioniert, wenn Du den Namen vorletzteZelle vergeben hast.
Aber wenn Du Dich mit dem Name-Vergeben nicht so auskennst, ist meine Lösung evtl. einfacher für Dich.

0
@Oubyi

... und wo bzw. wie definiere ich diesen Namen "vorletzte Zelle" damit er variabel ist?
doch nicht so:
mit Cursor auf Zelle J37
Einfügen / Namen / definieren /
"vorletzteZelle" bezieht sich auf =Tabelle1!$J$37
dann wäre es ja starr immer J37, das will ich ja gerade nicht.
Also wie dann???

0
@PinoGrigio

Name1 enthält deine Formel =ANZAHL2(J:J)-1
Name 2 enthält die Verkettung =VERKETTEN("J";Name1)
Die Summenformel heißt dann =Summe(J1:Name1)

0
@RBMannheim

abgesehen von dem J13
ergibt deine Formel =SUMME(J13:"J37"),
was Excel nicht auflösen kann,
deshalb geht's bei mir nur, wenn ich noch INDIREKT einfüge,
also so:
=SUMME(INDIREKT("J13:"&Name2))
trotzdem Danke

0

Ist die vorletzte Zelle vielleicht schon mit einer Formel belegt?

ob in der vorletzte Zelle eine Formel oder eine Zahl drinsteht ist nicht relevant,
ich möchte immer nur bis bis dahin summieren.

0

Excel Summe erweitern automatisch?

Guten Morgen,

ich habe ein Problem mit Excel. Ich habe eine Tabelle die mir unten die Summe der Anzahl ausgibt und diese Anzahl wird mit einem Preis multipliziert. Da ich die Formel Anzahl2 benutzt habe, ist die Tabelle ja begrenzt. Ich möchte es aber so haben, dass wenn ich eine neue Zeile einfüge, unten automatisch die Anzahl erhöht wird und somit auch der Betrag steigt. Wie mache ich das am besten?

lg

...zur Frage

EXCEL: Häufigkeit und Mittelwert der Zahl "4-12" in einer Spalte als Wert ausgeben

Formel 1: Wie gebe ich mit einer Formel die Häufigkeit der Zahlenwerte "4-12" einer Zeile aus? In der Zeile befinden sich Zahlen von "1-999".

Formel 2: Wie gebe ich außerdem den Mittelwert der Zahlenwerte "4-12" aus?

Formel 3: Wie gebe ich mit einer Formel die Häufigkeit der Zahl "999" einer Zeile aus?

Ihr meinen Patienten und mir (Auswertung für eine Doktorarbeit) sehr helfen, um die erhobenen Daten der letzten 4 Jahre auszuwerten... :) Vielen Dank im Vorraus! Die beste Antwort wird natürlich gekührt! :)

...zur Frage

Gibt es eine Möglichkeit, aus allen Excel Tabellen eines Ordners, eine bestimmte Zelle zu addieren?

Ich habe in einem Ordner Wochenabrechhnungen, dort wird immer in der selben Zelle der entsprechende Betrag x ausgegeben, nun wollte ich fragen, ob es möglich ist einfach zu sagen rechne mir von allen Tabellen in dem Ordner alle Zellen G12 zusammen als Beispliel.

Am besten ohne den Pfad jeder Datei einzeln anzugeben, Also mal übertragenen Sinne im Windows Stile:

=summe(Pfad/*.xls;Tabelle1!G12)

Ist sowas in der Richtung möglich?

...zur Frage

Wie kann man im Excel zwei Spalten automatisch addieren lassen in der dritten Spalte?

Hallo Leute,

ich möchte eine Excel Tabelle basteln. Habe leider nicht viel Ahnung.

In Spalte A kommt eine Zahl und in Spalte B kommt eine Zahl, nun soll automatisch in Spalte C die Summe von A und B erscheinen.

Habt ihr mal einen Tipp, wie das geht?

Vielen Dank

...zur Frage

Habe eine Excel-Tabelle & stelle einen ganzen Monat pro Mitarbeiter dar. Möchte den Urlaub errechnen, der als "U" gekennzeichnet wurde, als SummeGesamt. Wie?

...zur Frage

Excel Tabelle Differenz bilden?

Hallo Leute!

wie kann ich in Excel eine Tabelle mit 3 Spalten ABC erstellen von denen immer die Zeilen z.B. B1-A1=C1 ausgebgeben werden, aber dass ich diese Formel nicht überall hinschreiben muss. Gibt das da einen Weg? Sowas wie jede Zeile der Spalte B - jede Zeile der Spalte A = dazugehörige Zeile in Spalte C.

Soll für eine Art Fahrtenbuch dienen und ständig erweitert werden können ohne immer die Differenzformel anzugeben.

Mfg

Lazarys

...zur Frage

Was möchtest Du wissen?