Sortierung von 2 Excel Tabellen mit Artikelnummern nach 2 Kriterien?

...komplette Frage anzeigen

2 Antworten

Du könntest in Tabelle A eine Hilfsspalte anlegen mit der Formel (ausgehend, dass die Nummern in beiden Tabellen in Spalte A stehen, beginnend bei Zeile 2):

=ZÄHLENWENN(TabelleB!A:A;A2)

Diese Formel kopierst du nach unten. Wenn die Nummer gefunden wurde, steht eine 1, sonst eine 0. Jetzt kannst du die erweiterte Sortierung für mehrere Spalten verwenden.  https://support.office.com/de-de/article/Sortieren-von-Daten-in-einem-Bereich-oder-in-einer-Tabelle-62d0b95d-2a90-4610-a6ae-2e545c4a4654#bmsort_by_more_than_column_or_row

Antwort bewerten Vielen Dank für Deine Bewertung

Mit der Funktion VERGLEICH oder besser ZÄHLENWENN kannst du in einer separaten Spalte herausfinden, ob ein Artikel im Lager ist.

Darauf setzt du dann einen Filter.

Antwort bewerten Vielen Dank für Deine Bewertung
weisi88 11.01.2016, 14:49

Super danke schon mal. Kannst Du das ein klein bisschen ausführen bitte.

Also ich habe Tabelle (A) mit 5 Spalten. Alle haben überschriften in der ersten Zeile. Die erste Spalte ist die mit den Artikelnummer, 2-5, die mit den Artikeldaten.

Habe jetzt Tabelle (B) in Tabelle (A) kopiert, welche ja nur die Artikelnummer meines Lagers enthalten. Tabelle (B) ist nun in Spalte 6.

Hilft Dir das?

0
Suboptimierer 11.01.2016, 14:53
@weisi88

Nee, du sollst nichts kopieren.

Du hast eine Tabelle mit 800 Lagerartikeln und eine mit 2500 Artikeln, von denen du die Lagerartikel angezeigt bekommen möchtest. Steht die Artikelnummer jeweis in der ersten Spalte, fügst du am Ende der Tabelle mit 2500 Artikeln folgende Formel ein:

=ZÄHLENWENN(A2;Lager!A2:A100000)>0

Die Spalte betitelst du mit "Ist Lagerartikel". Auf ähnlicher weise kannst du mit SUMMEWENN die Artikel zählen, also die Frage über die reine Existenz hinaus beantworten.

2

Was möchtest Du wissen?