Schwere Aufgabenstellung in Excel

...komplette Frage anzeigen

2 Antworten

B1: =WENN((TEIL(A1;FINDEN(".";A1)-1;1)*1)<7;"X";"")

dann runterziehen

Iamiam 17.10.2012, 22:13

das DH gilt eigentlich der Formel in der AW von robich.

0

Ach hab mich vertan müsste A1 B1 C1 D1 heißen sry

augsburgchris 17.10.2012, 14:19

Dann

A2: =WENN((TEIL(A1;FINDEN(".";A1)-1;1)*1)<7;"X";"")

und rüberziehen ggg

PS: die Überschrift ist ein bisschen arg übertrieben!

0
robioh 17.10.2012, 14:35
@augsburgchris

Hammer...Danke für die super schnelle Antwort. Funktioniert!!! Ausser wenn es keinen Punkt gibt sonder z.B. nur V 7 da steht. Wenn die Zelle leer ist zeigt er auch einen Fehler an. Wäre Top wenn man das Problem auch lösen könnte. Anscheinend doch nicht so ein schweres Excelproblem, aber für die Anfänger wie mich schon.

Vielen Dank schonmal

0
augsburgchris 17.10.2012, 14:45
@robioh

Entscheidend ist die Zahl vor dem Punkt. Nach der soll gesucht werden

0
augsburgchris 17.10.2012, 15:02
@robioh

{=WENN(A1="";"";WENN(LINKS(SUMME((TEIL(0&A1;KGRÖSSTE(WENN(ISTZAHL(TEIL(0&A1;ZEILE($1:$300);1)*1);ZEILE($1:$300);1);ZEILE($1:$300));1)*1)*10^(ZEILE($1:$300)-1));1)*1<7;"X";""))}

ACHTUNG!

Das ist eine Matrixformel.

Das bedeutet: Die geschweiften Klammern {} NICHT mit eingeben und die Eingabe der Formel NICHT mit ENTER abschließen.

Schliesse stattdessen die Formel mit STRG & SHIFT & ENTER (alle drei gleichzeitig) ab, das erzeugt die {} und macht die Formel zu einer Matrixformel.

Die Formel erst nach dem Abschliessen mit Strg+Shift+Enter runter- oder rüberziehen

Quelle der Formel: www.excelformel.de

0
augsburgchris 17.10.2012, 15:07
@augsburgchris

hierbei wird jedoch nur auf die erste Zahl abgefragt

wenn deine Zelle also lautet "SP2 7.00" dann wird die 2 ausgelesen.

0
robioh 17.10.2012, 15:08
@augsburgchris

Ja stimmt aber wie gesagt die Eintragungen in so eine Datenbank sind nicht immer so vollständig. In dem Fall entweder 7. oder nur 7. Wenn jemand noch eine Verbesserung hat wäre ich sehr dankbar.

0

Was möchtest Du wissen?