Schachfeld bei Robot Karol programmieren? Habt ihr beispiele?

2 Antworten

hier Funktioniert einwandfrei

Anweisung Schach Wiederhole solange nicht istWand MarkeSetzen Schritt Wenn nicht istWand dann Schritt *wenn *Wiederhole *Anweisung wiederhole immer Schach LinksDrehen Schritt LinksDrehen Schach RechtsDrehen Schritt RechtsDrehen *wiederhole

Hier funktioniert einwandfrei

Anweisung Schach

  Wiederhole solange nicht istWand 

 MarkeSetzen

 Schritt 

 Wenn nicht istWand dann 

 Schritt 

*wenn 

 *Wiederhole

*Anweisung 

 wiederhole immer

Schach 

 LinksDrehen

 Schritt LinksDrehen

 Schach 

 RechtsDrehen 

 Schritt

RechtsDrehen

 *wiederhole

Was möchtest Du wissen?