Richtige Formel in Excel?

... komplette Frage anzeigen

3 Antworten

Etwas umständlich, aber funktioniert:

=ZÄHLENWENNS(B2:B200;"A";H2:H200;"A")+ZÄHLENWENNS(B2:B200;"B";$H2:$H200;"B")

Du musst nur für jede mögliche Antwort einen neuen Zählenwenns Summanden ergänzen.

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Iamiam
27.11.2015, 10:12

Wenns für die Schule ist, ist Deine AW wahrscheinlich die gewünschte.

Aber ich kann mich mit ZählenwennS einfach nicht anfreunden:

mir konnte noch niemand erklären, was der Vorteil gegenüber dem m.E. viel übersichtlicheren Summenprodukt in der o.g. AW sein soll.

2
Kommentar von evenangelscry
27.11.2015, 12:31

Vielen Dank! Funktioniert gut!

0

ohne Hilfsspalte:

=Summenprodukt((B:B=H:H)*1)

Diese Formel darf aber weder in Spalte B noch in Spalte H stehen.

Soll sie doch in B stehen, würde ich oberhalb des Kopfs(Zeile1?) eine neue Zeile1 einfügen und dann folgende Formel einfügen:

=Summenprodukt((B3:B333=H3:H333)*1)

Wichtig ist, dass eine gleiche Anzahl von Zellen verglichen werden, sonst gibts Fehler.

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Iamiam
27.11.2015, 10:07

Du kannst die Zeile nachher nach direkt unterhalb des Kopfs verschieben oder gleich von vornherein als Zeile2 anlegen (sie hat dann aber erstmal die Formatierungen der Kopfzeile).

Die Zeile aber NICHT INNERHALB DES AUSWERTEBEREICHS (hier 3:333, wahrscheinlich reicht auch 33 -dann aber bei BEIDEN SPALTEN!-) ansiedeln, sonst gibts Zirkelbezug!

0

Ich würde einfach hintendran Hilfsspalten machen mit der Formel =WENN(B2=H2;1;0)

Da steht dann bei einer richtigen Antwort eine 1 und bei einer falschen Antwort eine 0 drin. Die Spalte kannst du dann einfach mit =SUMME zusammenzählen.

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Sawascwoolf
27.11.2015, 09:51

alternativ kann man die Berechnung auch auf ein neues Tabellenblatt auslagern.

0

Was möchtest Du wissen?