RaspberryPi-SSH-Server funktioniert nicht - könnt Ihr mir helfen?

... komplette Frage anzeigen

3 Antworten

waren alle meine Daten weg, und ich konnte nochmal von vorne anfangen!

Triviale Sache: Backups helfen. Und zwar nicht nur vom home-Verzeichnis, sondern auch von /etc. Dann musst Du nur die Pakete neu installieren, spielst das Backup zurück, startest die Dienste neu und alles ist wie vorher. Wenn Citadel (oder eine andere Anwendung auf dem Pi) eine Datenbank verwendet, musst Du die natürlich auch sichern (bei MySQL ist das /var/lib/mysql).

Als ich dann aber versuchte mich von einem neuen Netzwerk unter
meiner Domäne anzumelden, hatte ich einen ConnectionTimeout! (Im lokalen
Netzwerk war es (auch unter meiner Domäne) genau das gleiche)

Also ist es egal, ob Du aus dem lokalen Netzwerk oder über das Internet kommst? Dann mache erst einmal alle Tests vom lokalen Netzwerk, um die Fehlerquelle no-ip etc. auszuschließen. Du hast mit ifconfig die IP-Adresse kontrolliert? Die ist per Ping erreichbar? Dann mache mal ein

 sudo service ssh status

Da sollte das herauskommen:

[ ok ] sshd is running.

Wenn nicht, hilft ein

sudo service ssh start

Wenn eine Fehlermeldung kommt, musst Du die erst einmal sinnentnehmend lesen und ggf. in die Logs schauen. Wenn der Server lokal erreichbar ist, dann probiere es über das Internet.

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Schrotti2002
16.01.2016, 23:52

Danke für den sehr hilfreichen kommentar, aber das Problem hat sich durch

sudo service ssh restart

von selbst gelöst ;-)

Der Citadel-Server lief übrigends nur im lokalen Netzwerk, und auch nur zu experimentellenn zwecken!

MfG Schr0tti

PS: Der SSH-Dienst war schon angeschaltet, musste aber wegen "HIER BITTE BEGRÜNDUNG EINFÜGEN" neu gestartet werden!

0

Der häufigste Fehler: Hast du die richtige IP Adresse?

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Schrotti2002
14.01.2016, 19:56

denke schon!

0
Kommentar von Manuauto
14.01.2016, 19:58

Ping 192.168.x.xx

0
Kommentar von Manuauto
15.01.2016, 15:28

Ja offensichtlich schon

0

Was möchtest Du wissen?