Raspberry Pi 4 bootet nicht?

 - (Computer, Technik, Technologie)

1 Antwort

Sicher ist: Die SD-Karte ist nicht in Ordnung.

Nach dem Restart kam allerdings eine Fehlermeldung.

Es wäre enorm hilfreich, wenn wir auch über den Inhalt dieser Fehlermeldung informiert würden.

Ich habe es wieder und wieder probiert

Was ist "es"?

aber nichts hat geholfen.

Was ist "nichts"? Ist "nichts" "es". Dann war es ja nicht viel. Wenn man etwas, was nicht funktioniert, mehrfach wiederholt, wird es nicht besser.

Ich nehme mal an, Du hast durch mehrfaches Trennen vom Strom die Karte zerstört.

Also: Noch einmal von vorn. Und Fehlermeldungen bitte im exakten Wortlaut.

Nein ich habe nicht den Pi ständig vom Strom getrennt. Ich habe die SD Karte wieder non-bootable gemacht und wieder geflash aber ich probiere jetzt die SD Karte in FAT zu formatieren vielleicht Hilft es

0
@MortexFx
Nein ich habe nicht den Pi ständig vom Strom getrennt.

Dann solltest Du einfach mal genau beschreiben, was Du gemacht hast.

Ich habe die SD Karte wieder non-bootable gemacht

Was auch immer das bedeutet: Es ist überflüssig. Wenn Du die SD-Karte neu beschreibst, werden die Partitionen aus dem Image blockweise geschrieben.

ich probiere jetzt die SD Karte in FAT zu formatieren vielleicht Hilft es

Wird es nicht. Siehe oben.

Ich habe den Eindruck, als wäre die SD-Karte defekt. Das "Flashen" ist kein dateibasierter Kopiervorgang. Dabei könnte ein defekter Block erkannt, markiert und ausgelassen werden. Beim "Flashen" wird das Image Block für Block auf die SD-Karte übertragen. Wenn ein Block auf der SD-Karte defekt ist, werden Daten in diesen defekten Block geschrieben und sind weg.

Nimm mal eine andere SD-Karte.

0
@franzhartwig

Die SD Karte habe ich heut erst gekauft aber probiere ich danke

0
@MortexFx
Die SD Karte habe ich heut erst gekauft aber probiere ich danke

Das Alter von Geräten sagt nichts darüber aus, ob sie defekt sind.
Es gibt genügend Geräte, die "out of the box" defekt sind.
Um so verwunderlicher, dass man immer wieder diese "Erklärung" hört.

Aber mal von Anfang an:
Wurde der Inhalt der SD-Card nach dem flashen verifiziert?
Wenn nicht, dann flashe noch mal mit balenaEtcher. Der verifiziert das geflashte nach dem schreiben automatisch.

0
@mchawk777

Habe es jetzt über eine andere SD Karte gemacht und jetzt Klappts!

Ich habe auch bei der ersten SD Karte über balenaEtcher geflasht aber als es Fertig war stand dort "Flasing failed" dann habe ich es nochmal probiert und dann hat es geklappt. Naja trotzdem Danke, ich werde die defekte SD Karte zurückgeben.

1
@MortexFx

"Flashing failed" ist ja schon ein sicheres Zeichen, dass da nicht alles glatt lief. Warum sollte das Flashen fehlschlagen? Die Wahrscheinlichkeit, dass die Karte bereits Schäden hatte, ist sehr groß. Bei normaler Nutzung fällt das erst mal nicht auf, weil ein defekter Block gekennzeichnet und gemieden wird.

Wenn jetzt nach dem Update des Systems wieder ein Fehler auftritt, solltest Du den genau lesen und beheben.

1
@franzhartwig
Die Wahrscheinlichkeit, dass die Karte bereits Schäden hatte, ist sehr groß.

Richtig - man muss sich immer vor Augen halten, wie filigran gerade Micro-SD-Karten sind.
Deshalb habe ich auch angefangen übers Netzwerk regelmäßige Image-Backups anzufertigen. Das erspart einem viel Arbeit, wenn mal eine SD-Karte während des Betriebs das Zeitliche segnet.

0
@mchawk777

Hm, dd im laufenden Betrieb? Ist das Ergebnis funktionsfähig? Schließlich wird die SD-Karte während des Backups verändert.

Ich minimiere Schreibvorgänge, indem ich Logs und Datenbanken z. B. von der SD-Karte auslagere. Auch /home/ ist ausgelagert. Und natürlich habe ich initial ein Backup der Karte mit dd gemacht, aus dem laufenden Betrieb mache ich Backups mit Borg - täglich und automatisiert.

0
@franzhartwig
Hm, dd im laufenden Betrieb? Ist das Ergebnis funktionsfähig? Schließlich wird die SD-Karte während des Backups verändert.

Ich hatte schon mit dem Etcher solche Images erfolgreich zurück geschrieben.

Allerdings muss ich dazu sagen, dass für ein Image einer MariaDB und einem mit pihole gemacht hatte, bei denen sich jetzt nicht ständig was ändert.
Außerdem habe ich noch nicht wirklich häufig einen Restore durchführen müssen.

Aber grundsätzlich scheint das zu laufen.
Ob das ähnlich der Schattenkopien wie in Windows funktioniert kann ich jetzt nicht beurteilen - aber Images im laufenden Betrieb herzustellen funktioniert ja grundsätzlich.

0
@mchawk777

Ich lasse das bei mir mal mitlaufen. Mehr als schiefgehen kann es ja nicht. Es ist ja nicht mein einziges Backup.

1

Was möchtest Du wissen?