Probleme mit WENN, WENN Verschachtelung

3 Antworten

Vom Fragesteller als hilfreich ausgezeichnet

SO könnte es schon eher klappen/ macht es mehr Sinn:

=WENN(NICHT(ISTNV(SVERWEIS(K27;Sonderfälle!F:G;1;FALSCH)));"falsch";WENN(NICHT(ISTNV(SVERWEIS(K27;Sonderfälle!I:J;1;FALSCH)));"ok";""))

Allerdings sind da noch einige "Ungereimtheiten".
Ich bin nicht sicher, ob ich überhaupt verstehe, was Du erreiche willst:
1. Du gibst als Matrix zwei Spalten an, als drittes Argument aber nur 1.
Es würde also eine Spalte als Matrix reichen (zwei schaden allerdings nicht wirklich).
2. Ist Dir klar, dass, wenn K27 in F gefunden wird "falsch" ausgegeben wird, auch wenn es zusätzlich noch in J steht (denn nach der ersten wahren Bedingung "steigt Excel aus", prüft die zweite also gar nicht mehr!
3. Welche Excel Version hast Du? Ab 2007 wäre die Funkion WENNFEHLER vielleicht hilfreich.

P.S.:
Das Ganze ließe sich auch - so ich es richtig verstanden habe - sinnvoller ohne SVERWEIS lösen, und zwar z.B. so:

=WENN(ISTZAHL(VERGLEICH(K27;Sonderfälle!F:F;0));"falsch";WENN(ISTZAHL(VERGLEICH(K27;Sonderfälle!I:I;0));"ok";""))

Oder?

2
@Oubyi

Erstmal vielen Dank, hat super geklappt.

Zu deinen Fragen:

  1. Ich brauche nur eine Spalte, aber es hat nicht geklappt bei mir, mit zwei dann aufeinmal schon?! Aber mit der jetzigen Formel in einer Spalte klappt das super :-)

  2. Das macht nichts, denn in 99,99% der Fälle gibt es nur entweder oder und das letzte 0,01% kann ich mit gutem Gewissen ausblenden.

  3. 2007 und hatte es auch mit WENNFEHLER gemacht, nur hier zum Pasten, hab ich das unwichtige weggelassen.

Aber erklär mir mal bitte, was es mit dem NICHT aufsich hat, denn für mich heißt die Formel: Wenn nicht K7 in Sonderfälle, dann "falsch" wobei die Ausgabe genau anders herum ist und es wird angezeigt, wenn es vorhanden ist :-)

0
@Oubyi

Aber rein aus Interesse, wie könnte ich es regeln, das wenn die Zahl in beiden Spalten gefunden wird, z.B. ein dritter Wert ausgegenen wird? Nennen wir diesen Wert "ok und flasch"

0
@Sven8219

Aber erklär mir mal bitte, was es mit dem NICHT aufsich hat, denn für mich heißt die Formel: Wenn nicht K7 in Sonderfälle, dann "falsch" wobei die Ausgabe genau anders herum ist und es wird angezeigt, wenn es vorhanden ist :-)

Da steht nicht nur NICHT, sondern:
(NICHT(ISTNV(....
"Zu Deutsch": Wenn der SVERWEIS nicht #NV liefert - also positiv ausgedrückt: Wenn der SVEWEIS etwas findet - dann mache ...

Aber rein aus Interesse, wie könnte ich es regeln, das wenn die Zahl in beiden Spalten gefunden wird, z.B. ein dritter Wert ausgegenen wird? Nennen wir diesen Wert "ok und flasch"

Das müsste so klappen:

=WENN(ISTZAHL(VERGLEICH(K27;Sonderfälle!F:F;0));WENN(ISTZAHL(VERGLEICH(K27;Sonderfälle!I:I;0));"ok und falsch";"falsch");WENN(ISTZAHL(VERGLEICH(K27;Sonderfälle!I:I;0));"ok";""))

Teste mal genau.

0
@Oubyi

P.S.:
ZÄHLENWENN(...) > 0
statt VERGLEICH ist übrigens auch noch ein - gleichwertige - Alternative.

0

Ändere doch mal den Bereich des zweiten SVERWEISes (bisher ";J;") in ";J:J;"

Dann sollte es besser sein.

Gruß aus Berlin

Da steht:

"I:J"

auch wenn es durch das vorangehende "!" schlecht lesbar ist!

0

Was passiert denn, wenn Du nur eingibst =WENN(SVERWEIS(K27;Sonderfälle!I:J;1;FALSCH);"ok";"") …?

das klappt. Alles im Einzelnen funktionert, nur zusammen eben nicht.

0

SVERWEIS; WERT AUS ZELLE IM SVERWEIS BENUTZEN

Hallo,

zunächst einmal möchte ich sagen, dass ich hier neu bin und es in keinem Forum eine ähnliche Frage war.

Aus diesem Grund verfasse ich hier mein Anliegen.

Ich arbeite mit dem Programm Microsoft Offe (Excel) 2003.

Ich suche eine Lösung für folgendes:

Ich möchte mit einem SVERWEIS den Wert aus einer Zelle in einer Tabelle auf nem anderen Tabellenblatt suchen.

Nur möchte ich den Wert in der Formel so suchen, dass wenn der Wert in der Zelle geändert wird sich das automatisch auch im sverweis überträgt.

habe z.B. folgendes versucht:

=SVERWEIS(WERT(A25);Tabelle1!$A$2:$B$388;2)

Ich bedanke mich jetzt schon einmal für die Antworten.

Lg

MS

...zur Frage

Kann man die Mittelwert und die Sverweis Funktion mischen?

Ich habe in einer Zeile die Tage, in einer Zeile die Kalenderwoche und in der dritten ein wert und ich brauche den Mittelwert von den ganzen werten pro Kalenderwoche

...zur Frage

Google Spreadsheet: Die Funktion 'SVERWEIS' funktioniert nicht. Warum?

Hallo,

ich benutze die folgende Formel in meiner Google-Tabelle (in Zelle H16): =SVERWEIS("";F7:F18;7;FALSCH).

Ich möchte, dass im Bereich F7:F18 die erste Zelle ohne Inhalt gefunden wird und dann die entsprechende Zeile der 7ten Spalte wiedergegeben wird.

Alles, was ich bekomme, ist #REF!. Allerdings stimmt die Referenz, den im Bereich F7-F18 gibt es nur einen einzigen Eintrag, nämlich ein Datum, dass in F7 steht.

Was mache ich falsch?

Danke im Voraus.

...zur Frage

Wie lautet die Formel wenn ich die SVERWEIS Funktion mit der SUCHEN Funktion verknüpfen will?

Es geht darum, dass in den Zellen in der die Sverveis Formel sucht, links vor der Zahl ein Buchstaben ist. Sverweis soll nun aber die Zeile auch finden, wenn nur die Zahl eingegeben wird.

...zur Frage

=WENN(ISTNV(SVERWEIS(A5;"So";1;FALSCH));"";"j") noch einen zusatz?

ich habe folgnde Formel in P5:

=WENN(ISTNV(SVERWEIS(A5;"So";1;FALSCH));"";"j")

Kann ich dieser Formel noch einen Zusatz verpassen wie folgt:

wenn in O5 bereits auch ein "j" dass es dann in P5 nichts anzeigen soll?

...zur Frage

Was möchtest Du wissen?