Probleme mit Excel - wenn und Sverweise zusammen legen?

... komplette Frage anzeigen

1 Antwort

Ich bin nicht unbedingt der Spezialist für das Rechnen mit Uhrzeiten (das ist ein Graus!)

Bei mir funktioniert die Abfrage auf B3<"12:00" aber in dieser Form auch nicht. Excel rechnet Uhrzeiten im Grunde als Bruchteil von 1 (s. bspw. hier: http://www.office-loesung.de/ftopic37654\_0\_0\_asc.php)

Wenn Du die Bedingung änderst auf

B3<12*1/24 sollte es gehen.

Vielleicht kannst Du die Formel auch deutlich kürzen. Wenn B3 entweder kleiner oder größer/gleich 12:00 ist und andere Fälle nicht auftreten können (wie leer)

=WENNFEHLER(WENN(B3<12*1/24;SVERWEIS(A3;'Vorlage früh'!A:C;2;FALSCH);SVERWEIS(A3;'Vorlage spät'!A:C;2;FALSCH));"")

An der Stelle aber noch zwei Punkte:
1. Ist es korrekt, dass B3 auf < bzw. >= geprüft wird, dann aber mit A3 gesucht wird?
2. Der Suchbereich A:C könnte eigentlich auch A:B sein, weil ja nur zwei Spalten relevant sind.

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Sorgenfalten
14.01.2016, 12:33

Hallo. Danke für die schnelle Antwort. Die Formel funktioniert sehr gut und. Die Suchen sind richtig um deine Frage zu beantworten. Er muss nach der Uhrzeit schauen und wenn die kleiner als 12:00 Uhr ist, dann soll er nach dem Markt (A3) in den jeweiligen Vorlagen suchen. Den Suchbereich habe ich mit A:C definiert, weil ich die gleiche Formel für die nächste Suche benötige und da wird die Spalte C benötigt. Wie gesagt funktioniert perfekt. Danke. Jetzt könnte ich noch eine kleine Erweiterung benötigen. Wenn er jetzt in den Vorlagen nichts findet schreibt Excel immer "0". Schön wäre eine Lösung das Excel gar nichts schreibst. Kann mir da nochmal jemand helfen.

0

Was möchtest Du wissen?